WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
https plugin issue - admin site redirecting to home page (1 post)

  1. shailesh.deodhar
    Member
    Posted 8 months ago #

    Hi,

    We have setup WordPress in Windows 2008 Server, IIS 7. We have following settings in wp-config file.

    define('WP_SITEURL', 'http://10.190.94.38');
    define('WP_HOME', 'http://10.190.94.38');

    10.190.94.38 is our IP address for external world i.e. internet.

    We have installed https plugin. We have configured it to use specific SSN host (10.0.0.5) and have checked Force SSL for admin site. This 10.0.0.5 is internal IP address and this way we are allowing admin site to be accessible over https on internal network.

    We have managed to put on rules in IIS to block traffic to wp-admin virtual folder.

    The site is working fine with above configuration.

    What we want is to enable multisite for WordPress. So we added following in wp-config.php file.

    define('WP_ALLOW_MULTISITE', true);

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', '10.190.94.38' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    We then created second blog by name 'test'. So now we have following blogs

    Blog 1
    http://10.190.94.38/blog/

    Blog 2
    http://10.190.94.38/test/

    To be able to enable multisite feature, we had to disable all plugins (including https) before doring multisite changes. After we were done with it, we enabled all plugins (including https) at network level. SSL host in https plugin settings was then got changed to 10.190.94.38. So we went ahead and updated to 10.0.0.5 for both blogs.

    Now if we are trying to access admin site for any of the blog it is always redirecting to home of first blog. Could you please provide some help.

    Just to highlight, we are using 3.3.6 version of https plugin.

    http://wordpress.org/plugins/wordpress-https/

Reply

You must log in to post.

About this Plugin

About this Topic

  • RSS feed for this topic
  • Started 8 months ago by shailesh.deodhar
  • This topic is not resolved
  • WordPress version: 3.6.1