WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
HTTPS on subdomain / issues when viewing regular domain (14 posts)

  1. cyphog
    Member
    Posted 1 year ago #

    Hi there,

    I have an SSL cert installed on a subdomain -- https://secure.domain.com -- and my WP installation on the main domain -- http://domain.com.

    When I have WordPress HTTPS activated, pointing the SSL Host to secure.domain.com, and Force SSL Login / Admin selected, everything works fine on the admin end, but when I view the site (domain.com) I no longer can see the WordPress admin bar and it treats me as a non-authenticated user.

    Also, when I try to preview a post or page through the admin panel (secure.domain.com) it 404's those preview pages.

    I've tried resetting the permalinks (which would only take care of the latter issue, if it worked) with no luck.

    I've installed/reinstalled the plugin -- no luck.

    I've disabled other plugins -- no luck.

    If I disable the plugin and hit the admin panel through domain.com/wp-admin, everything is peaches and I can see the admin bar when viewing the site, and can also preview posts and pages.

    Absolutely flummoxed. Any ideas?

    http://wordpress.org/extend/plugins/wordpress-https/

  2. cyphog
    Member
    Posted 1 year ago #

    Please ignore. It seems to have been a plugin conflict after all (at least, I hope it's all better now).

  3. cyphog
    Member
    Posted 1 year ago #

    Sorry, I marked as "resolved" thinking it was a plugin conflict and thinking I'd fixed it, but I'm still experiencing the above issues across multiple browsers (FF, Chrome, IE) and multiple systems (2 different Win7x64 machines), and I don't believe it's a plugin conflict.

    When I log into my admin panel via the https subdomain I have set up (https://secure.domain.com/wp-login.php) and then go to view the regular blog site on http://domain.com it doesn't seem to recognize that I'm an authenticated user. No admin bar at top, etc. Trying to preview any posts or pages via the admin panel results in 404's. However, already published blog content is fine and viewable to outside users.

    My current workaround: 1) Disable WordPress HTTPS plugin. 2) Log into http://domain.com/wp-login.php. 3) Confirm that site is viewable as logged in user, draft posts can successfully be previewed, etc. 4) Renable HTTPS plugin, which automatically switches me back to https://secure.domain.com/wp-admin, where 5) I can successfully view http://domain.com as a logged in user, preview drafts successfully, etc.

    Really would like to get this sorted. Thx!

  4. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Enable debug mode and check the browser's console. See if it says Subdomain: Yes or No. I could see this being an issue if that says 'No'.

    Look at the cookies being set and check the domain they're being set on.

  5. cyphog
    Member
    Posted 1 year ago #

    Subdomain is set to No.

    [BEGIN WordPress HTTPS Debug Log]
    
    Version: 3.3.6
    HTTP URL: http://kimpluscraig.com/
    HTTPS URL: https://secure.kimpluscraig.com/
    SSL: Yes
    Diff Host: Yes
    Subdomain: No
    Proxy: No

    Which cookie(s) should I be looking for? Sorry, I can pull them up in a browser but I'm not overly familiar with what I should be hunting for in regards to the plugin and the site.

  6. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    It's cool, I know what the issue is. I won't go into to too much detail, but the subdomain check relies on a cURL request and if that fails for some reason, it won't detect that the SSL Host is a subdomain of the regular host and set cookies appropriately. Some hosts have issues with the cURL request, although most don't.

    I'm working on a new version and this is one thing I'm going to be improving/fixing/removing. I'll update the topic when I have something you can test.

  7. cyphog
    Member
    Posted 1 year ago #

    Brilliant, thanks!

  8. LO
    Member
    Posted 11 months ago #

    Hello,

    I am experiencing the exact same issue on my server, and my console displays the same as reported by cyphog.

    Is there a status update on this fix?

    If the setting is still needed, would it make sense to change the subdomain check from happening automatically via curl to happening via a user input on the settings page?

    Thanks for your work.

  9. cyphog
    Member
    Posted 11 months ago #

    Hi,

    Wondering what the status is of the fix?

    Thx!

  10. xLRDx
    Member
    Posted 9 months ago #

    Dont mean to bump a thread but as i am having the same issue as of now witht he latest plugin version on wp 3.5.2 and was just curious if this is fixed or not?

  11. Arturo emilio
    Member
    Posted 9 months ago #

    Hi, i've just developed a new plugin that will allow your blog to login using HTTPS and a subdomain of your choice. Then get back to the previous page using HTTP.
    You may download it from here:
    http://arturoemilio.es/2013/07/23/login-en-wordpress-a-traves-de-un-subdominio-ssl/

    You may see the plugin working here: http://arturoemilio.tk.

    It is still pending review from wordpress repository so i may advise you to check from time to time to see if the plugin is being updated. Also any comments are welcome.

    Regards.

  12. LoneWolf95665
    Member
    Posted 8 months ago #

    I am having page 404 errors also on the "pages" of the subdomains. For example JessiesCorner.EverygthingAgricultural.com.

    I am new here..so please forgive any mistakes...

    The site is visible but when I click on a link... a page 404 error displays. How can I fix this for this site and other subdomain under EverythingAgricultural.com ?

  13. LO
    Member
    Posted 7 months ago #

    Has anyone tried the solution mentioned here: modifying the cookie domain?

  14. chrismartino
    Member
    Posted 4 months ago #

    I'm having this exact same issue.

    Console says:

    [BEGIN WordPress HTTPS Debug Log]
    Version: 3.3.6
    HTTP URL: http://chrismartino.com/
    HTTPS URL: https://secure.chrismartino.com/
    SSL: Yes
    Diff Host: Yes
    Subdomain: No
    Proxy: No

    Any help is appreciated.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.