WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
https not working on blog/post pages (11 posts)

  1. scott74
    Member
    Posted 2 years ago #

    i have all my pages working with chrome but the blog/post pages come up with a yellow triangle by the https instead of green saying that some items may not be encrpyted..

    Also i have added the code in the wp config file to make the login and admin area secure.. it was working before but now I get the yellow triangle also in the admin area but not the login page..

    This is with google chrome browser

    any help appreciated..

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey scott74,

    This is the infamous partially encrypted error that many users run into, and the plugin does its best to prevent. To identify what's causing these errors, please follow my instructions under "How do I fix partially encrypted errors?" in the FAQ.

    Also, please list all of the options you have enabled.

    Thanks,
    Mike

  3. scott74
    Member
    Posted 2 years ago #

    Hey Mvied, thanks for the quick reply... for some strange reason it is working on the blog pages now.. just have small issue with the wp admin area..

    I am using this snippet for the admin area.. was working yesterday but have the google error now in admin area..

    admin over ssl

    I wanted to use the force ssl on specific pages but that didnt work.. kept getting the redirect error in google chrome so using it globaly.. here are a few screen shots of whats going on..

    screen 1
    screen 2
    screen 3

    Ps.. is there a fix to force ssl without the redirect error.. i would only like to uss ssl on the payment part of site.. i heard it can slow site a little by using on every page

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey scott74,

    I imagine you're having the same redirect issues many users were having. Try downloading the development version and replacing the wordpress-https.php file in /wp-content/plugins/wordpress-https/ with the one located in the zip archive. This may even fix the partially encrypted error you're receiving in the admin panel.

    With Google Chrome, once it encounters something that's not secure, the triangle will appear and it will not go away even if you refresh the page and the unsecure element is gone. The only way to test the page again is to close the tab and reopen the page. Once you encounter the partially encrypted error again, you'll need to identify what elements are causing the issue by following my instructions under "How do I fix partially encrypted errors?" in the FAQ.

    Thanks,
    Mike

  5. scott74
    Member
    Posted 2 years ago #

    Thank you... the new https.php file gave me a new settings screen with less options correct??

    I did manage to fix the admin screen per your instructions... it was 2 pics from white lable branding and tech support plugin here

    culprit

    errors

    fixed by using this site to host those two pic and replacing with url..

    I selected force ssl but all my pages are still ssl and only want a couple... is this because i replaced the file https.php before deselecting the other options??

    new options with new file

    Old opetions

    thanks again Scott

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Scott,

    Is your site url still set with an HTTPS address? If so, you'll want to change it back to HTTP.

    Also, I was working with another user and they noticed that the Force SSL Exclusively option wasn't forcing pages back to HTTP and I made a modification to the development version to fix it. Try downloading the development version again and see if that fixes it.

    Thanks,
    Mike

  7. scott74
    Member
    Posted 2 years ago #

    you mean this one..... This has always been http i believe

  8. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Scott,

    Yeah, got confused with the other thread I'm actively supporting.

    Either way, update to the newest development version and see if that fixes it.

    Thanks,
    Mike

  9. scott74
    Member
    Posted 2 years ago #

    you mean just that one file that you provided in the link above with the https.php file in it.. or is there a a different zip..? the one you led me to just had the https.php file in it

  10. scott74
    Member
    Posted 2 years ago #

    i replaced that file twice but could not get the force ssl to work.. i just have ssl on all pages

  11. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Scott,

    Do you mind if I take a look at it? If not, email an admin login to mike[at]mvied[dot]com.

    Thanks,
    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic