WordPress.org

Ready to get started?Download WordPress

Forums

HTTPS local SSL verify and WP_Cron (3 posts)

  1. nddery
    Member
    Posted 1 year ago #

    Hey,

    I have a site that is running over SSL and we are currently experiencing problems with WP_Crons, they do not run. I have activated the WP-Crontrol plugins and I get the following error message when accessing the "Crontrol" page.

    There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron jobs on your site may not work. The problem was:
    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    I have found this trac ticket that provides a solution (the "add_filter" by nacin) that works.

    I am wondering if this solution would in any way make the site less secure or if there is a better/nicer solution. The host says the SSL certificate is installed correctly.

    Thanks!

  2. TWGerard
    Member
    Posted 1 year ago #

    I too would like an answer to your question. The filter seems a little bit sketchy to me, but I found an alternative solution:

    Just add define( 'ALTERNATE_WP_CRON', true ); to your wp-config.php file.

    This does the trick for me and seems to be the appropriate fix for our problem.

  3. nddery
    Member
    Posted 1 year ago #

    I've read somewhere that there is a chance, when using ALTERNATE_WP_CRON, that the "doing_wp_cron" parameter shows in the URL, which is ugly - not to mention that it could cause problems (OK, small problems) if people bookmark the page or send it to friends.

Topic Closed

This topic has been closed to new replies.

About this Topic