WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] HTTPS Disables WPTouch (4 posts)

  1. sassymonkey
    Member
    Posted 1 year ago #

    I run a site that uses WPTouch Pro (http://galleryrouteone.org). I often find that WPTouch is not working on a mobile device and the desktop theme is showing instead.

    I finally discovered that deactivating WordPress HTTPS will remedy the problem. Interestingly, if I reactivate HTTPS the mobile version still functions properly. Unfortunately, this seems to be temporary and the mobile version becomes mysteriously disabled again.

    The only setting I have chosen for HTTPS is to force it on when viewing admin pages.

    I don't have anymore info though. I haven't found the problem enough to know how long it happens or if it follows something else I'm doing on the site such as publishing content or updating core/plugins. It seems intermittent.

    Any ideas? I thought maybe since WPTouch Pro requires a license that it needs to communicate with its mothership to validate or whatever and that HTTPS is maybe blocking that. But I can't find any info about whether this is true and how would I fix such a problem even if I knew the URL WPTouch used to validate?

    Thanks for any help.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. BraveNewCode Inc.
    Member
    Posted 1 year ago #

    We provide support for WPtouch Pro exclusively through our customer support forums, please login and post your question there along with a specific url where we may troubleshoot the issue:
    http://www.bravenewcode.com/support/

  3. airdrummer
    Member
    Posted 1 year ago #

    i'm using the free version of wptouch, and i also thought https4wp was the culprit, but disabling https4wp didn't fix the problem, so it looks like wptouch is incompatible w/ssl...or w/netsol's vps hackery;-\

  4. BraveNewCode Inc.
    Member
    Posted 1 year ago #

    @airdrummer, when you see cached mobile pages being served to your desktop or vice-versa, it is usually a caching plugin or service at the root of it. You may configure your caching plugin not to cache mobile pages nor to serve cached pages when mobile devices are detected. To do so, enter the user agents found under Advanced Options > Custom User-Agents to the "rejected user agents" areas in your caching plugin's settings. Remember to clear your plugin, browser, and device caches before retesting.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags