WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
https admin serves up http hrefs to stylesheets and js (1 post)

  1. gallussteve
    Member
    Posted 1 year ago #

    We saw this before on Chrome but firefox was ok so we ignored for a while - now there is a workaround for firefox - to remove the 'protection' the browser gives you and load unsecure content.
    What is happening is - with https admin enabled, pretty much everything works except stylesheet elements are served with http:// hrefs.
    Most- but not all - see:
    e.g.

    <link rel='stylesheet' href='http://MYSITE/wp-admin/load-styles.php?c=0&dir=ltr&load=admin-bar,wp-admin,buttons&ver=3.5.2' type='text/css' media='all' />
    <link rel='stylesheet' id='scep_style-css'  href='http://MYSITE/wp-content/plugins/shortcode-exec-php/shortcode-exec-php.css?ver=3.5.2' type='text/css' media='all' />
    <link rel='stylesheet' id='simplemodal-css'  href='http://MYSITE/wp-content/plugins/shortcode-exec-php/simplemodal/css/basic.css?ver=3.5.2' type='text/css' media='all' />
    <link rel='stylesheet' id='fppg-style-css'  href='http://MYSITE/wp-content/plugins/facebook-page-photo-gallery/templates/css/style.css?ver=3.5.2' type='text/css' media='all' />
    <link rel='stylesheet' id='admin_menu_tree_page_view_styles-css'  href='https://MYSITE/wp-content/plugins/admin-menu-tree-page-view/css/styles.css?ver=2.6.5' type='text/css' media='all' />
    <link rel='stylesheet' id='cfblbcss-css'  href='MYSITE/wp-content/plugins/cardoza-facebook-like-box/cardozafacebook.css?ver=3.5.2' type='text/css' media='all' />
    <link rel='stylesheet' id='comprehensive-google-map-style-css'  href='http://MYSITE/wp-content/plugins/comprehensive-google-map-plugin/assets/css/cgmp.admin.css?ver=7.0.31' type='text/css' media='screen' />
    <link rel='stylesheet' id='colors-css'  href='https://MYSITE/wp-admin/css/colors-fresh.min.css?ver=3.5.2' type='text/css' media='all' />

    We have HTTPS enabled for the /store/ area of the site and that works perfectly.

    Javascript is also having the same problem on the admin area:

    <script type='text/javascript' src='http://MYSITE/wp-admin/js/common.min.js?ver=3.5.2'></script>
    <script type='text/javascript' src='https://MYSITE/wp-content/plugins/admin-menu-tree-page-view/js/jquery.highlight.js?ver=3.5.2'></script>

    Any suggestions/ideas?

    Thanks.

    http://wordpress.org/plugins/wordpress-https/

    [Moderator Note: No bumping, thank you.]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic