WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] HTTP Upload Crunching Error (Running on IIS 7.5) (3 posts)

  1. dcarrio
    Member
    Posted 2 years ago #

    I am running a locally hosted wordpress site on a WHS 2011 (IIS 7.5) box. I made all required wordpress (php.ini) settings to allow me to upload video files larger than 2mbs (i am shooting for over 1gb files).

    Even though wordpress showed that it would accept 1024m files, i was still getting this crunch error, after looking at a TON of post about modifying file permissions, adding mime extentions, increasing image pixel sizes..... but realized a few mins ago that I was able to upload ANY file as long as it was under 25mb...

    I then decided to see if perhaps iis was limiting my file size and SURE enough i came across this post .
    Click on "Modifying the IIS 7.0/7.5 configuration (Windows Server 2008, Windows Server 2008 R2)" and it will explain how to make the needed change.

    Incase the site goes down, here is what you need to change;
    Request Filtering > Edit Feature Settings:
    Set 'Maximum allowed content length' to your desired file size (in bytes) e.g. '536870912' for 512MB (default is approximately 28.6MB)

    I restarted the IIS service and WALLA, i was able to upload any file up to 1gb in size.

    I only expect this setting to work if your hosting your own site, as people mentioned how they contacted their "host" and it just started working... i assume this is what they did.

    Also this is an IIS setting, so apache people, if your having the problem see if there is a similar setting in your web server config.

    I hope this helps others as I have been stuck for a weekend on trying to solve this issue.

  2. cfleek
    Member
    Posted 2 years ago #

    I am looking for instructions on installing WordPress on WHS 2011. Do you know where to find them? I know of an installer for V1, but I can't find one for 2011

  3. T Klein
    Member
    Posted 2 years ago #

    I just wanted to say thanks, I was having a similar problem and this solved the problem for me.

    The woes of IIS and wordpress... Why does Microsoft feel the need to limit you in multiple spots?

Topic Closed

This topic has been closed to new replies.

About this Topic