WordPress.org

Ready to get started?Download WordPress

Forums

HTTP to HTTPS with SSL not working with my .htaccess file (3 posts)

  1. iainq360
    Member
    Posted 1 year ago #

    Hi there,
    This is my first time posting on the support site. I normally find answers to questions by rooting around, but im a bit stumped on this one, so any help is much appreciated.

    As the title suggests i aim to use a .htaccess file to in effect push the HTTP to HTTPS. I have purchased an SSL certificate and contacted the web hosting company for support, but they won't assist any further.

    My current .htaccess file (which doesn't work) looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^(.*)$ https://www.thebranddesignco.co.uk/$1 [R=301,L]
    </IfModule>
    # END WordPress

    When i type http:// or just www. it goes to the https:// which is great, but the page is blank. I have tried setting in general settings the URL of the site to HTTPS://thebr... but still it just blanks.

    I also tried changing both boxes to https:// and making a couple of other changes somewhere which i can't remember where now. This completely failed, so i changed back and its all working fine on HTTP again.

    Any questions please feel free to ask, or if you want me to elaborate on anything just ask.

    Many thanks
    Iain

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    have tried setting in general settings the URL of the site to HTTPS

    See Changing_The_Site_URL for details of how to do this.

  3. iainq360
    Member
    Posted 1 year ago #

    Hi Thanks for the reply. Yes I have tried this and it only makes links once you are in the page https - it doesn't forward the homepage to HTTPS.

    Also it seems to muck up the stylesheet which is why i have had to change it back.

Topic Closed

This topic has been closed to new replies.

About this Topic