WordPress.org

Ready to get started?Download WordPress

Forums

Multiple content blocks
[resolved] HTTP Request Error when working on other sites on the same server (10 posts)

  1. wsme123
    Member
    Posted 1 year ago #

    I'm getting the following error when I go to create a new page:

    "Your server doesn't allow remote HTTP requests using wp_remote_get. You will have to visit this page manually to update which blocks are used on each page."

    Existing pages don't show anything at all to do with Multiple Content Blocks. I've tried moving around where <?php the_block("Below Services"); ?> is sitting in the template but it doesn't change anything.

    We've used multiple content blocks several times without any issues, using the same base theme framework and sitting on the same server without any issues - any ideas?

    Thanks,
    Emily

    http://wordpress.org/extend/plugins/multiple-content-blocks/

  2. Trendwerk
    Member
    Plugin Author

    Posted 1 year ago #

    This is a known bug on new pages, we're working on it. However, on existing pages, this should work.

    Do you see a meta box at all? Or do you just see nothing? Are you sure the right template is used?

  3. voldby
    Member
    Posted 1 year ago #

    I got the same problem.

    There is no meta box at all and I have put the php (the_block) in the default page (page.php).

    The only solution I have figured out is to disable the plugin, and enable it.

    Looking forward to the next release of the plugin, as I am using it a lot. Thanks.

  4. Trendwerk
    Member
    Plugin Author

    Posted 1 year ago #

    So you do see a meta box when you disable and enable the plugin again? And the plugin works fine after that?

    I hope we get some time in the near future to improve this.

  5. wsme123
    Member
    Posted 12 months ago #

    Sorry, I never saw the notification for a response to this.

    What happened was the block wouldn't show up in the admin area at all, when I created a new page if gave me an error message (as per my initial ticket).

    We have used this plugin before using the same base template, sitting on the same server, without any issues. I have used it on several sites since then without any issues as well.

    It is still not showing up on this site however (http://testcart.co.nz/conhur/ - homepage template)

  6. wsme123
    Member
    Posted 12 months ago #

    Disabling and enabling the plugin has no affect - I don't see anything in the back end when the homepage template is selected

  7. Trendwerk
    Member
    Plugin Author

    Posted 11 months ago #

    You can try this:

    1. Comment lines 101 and 102 of assets/inc/class.MCB.php
    2. Visit the page on which you have put the template tag in the front end
    3. Visit the page in the back-end editor

    Does this help?

  8. Trendwerk
    Member
    Plugin Author

    Posted 11 months ago #

    Can you try installing version 3.1 and selecting the option "Disable HTTP Requests" in the new settings page?

    You can manually refresh you blocks after that by visiting the front-end.

  9. wsme123
    Member
    Posted 11 months ago #

    Hello,

    Updating it worked after I changed the code of my home template around as well to add in an additional loop around the block.

    Thanks!

  10. Trendwerk
    Member
    Plugin Author

    Posted 11 months ago #

    No problem!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.