WordPress.org

Ready to get started?Download WordPress

Forums

http links changing to https when I login to wp-admin (3 posts)

  1. t8shter
    Member
    Posted 3 years ago #

    Hi,

    Each time we login to wp-admin, links in the navigation bar that should be http change to https ...

    To reproduce I browsed to http://www.mysite.com in 1 tab of firefox. I hovered over the nav bar and the links were http. I logged into wp-admin in another tab, then hovered over the nav links in the other tab (after refreshing the page) and they were all https. If I sign out and refresh the page again, they go back to http.

    This causes mixed-content errors, which is bad.

    Is this a bug with nav, super-cache, wordpress in general? Is there a setting I can tweak somewhere to prevent this?

  2. t8shter
    Member
    Posted 3 years ago #

    when I delete the wp-supercache the problem goes away for a while.

  3. kansascoder
    Member
    Posted 3 years ago #

    Generally you want to enforce ssl on login pages and for all pages on your admin section. This is for security purposes. There are tags you can put in your wp-config file to remove this though. If I remember correctly it is define('force_ssl_admin', false) but use at your own peril.

Topic Closed

This topic has been closed to new replies.

About this Topic