WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
HTTP errors when uploading (12 posts)

  1. nickth
    Member
    Posted 1 year ago #

    I get these HTTP errors when uploading images:
    http://www.screencast.com/t/CH7y1YArB1
    http://www.screencast.com/t/tBlVR1W2q

    When I deactivate the WP Smush.it plugin, then it works.

    Does this plugin not work when used with CloudFlare?

    http://wordpress.org/extend/plugins/wp-smushit/

  2. Could you please try if that happens with version 1.6.2 too?
    You can download previous versions from http://wordpress.org/extend/plugins/wp-smushit/developers/

    Cheers,
    Ari.

  3. B_Dark
    Member
    Posted 1 year ago #

    Hello @aristath, i have the same problem (without the cloudflare)...

    i tested with 1.6.2, 1.6.3, 1.6.4 & developer version

    i think the problem is only if someone theme have customize image sizes add on functions.php theme. if they don't use or just use the 3 native sizes on wp media section we don't get any http error. i think the problem is just the customize image sizes

    add_theme_support( 'post-thumbnails' );
    add_image_size('customize_image_1', 460, 9999, false);
    add_image_size('customize_image_2', 700, 9999, false);
    add_image_size('customize_image_3', 438, 9999, false);
    add_image_size('customize_image_5', 60, 9999, false);

  4. @b_dark so if for example you use the plugin with the twentytwelve theme that doesn't use any custom image sizes you don't get these errors but you get them if your theme specifies image sizes other than the default ones?

    @nickth could you please try using the twentytwelve theme so that we may verify that it is indeed an image_size issue?

    Cheers,
    Ari.

  5. B_Dark
    Member
    Posted 1 year ago #

    @aristath
    yes,exactly :)

  6. @b_dark ok.

    @nickth can you please verify that this is also the case with you so that I report this as an official bug and the plugin developer finds a solution?

    Cheers,
    Ari.

  7. B_Dark
    Member
    Posted 1 year ago #

  8. @nickth please read this post too:
    http://wordpress.org/support/topic/smushit-error-could-not-get-the-image-while-processing?replies=5#post-4077403

    It explains why you may be having this issue with cloudflare.

    Cheers,
    Ari.

  9. B_Dark
    Member
    Posted 1 year ago #

    what about my case without cloudflare? :P

  10. An update is coming pretty soon... So far it looks as if this issue has been resolved in the latest release.
    Stay tuned and please update as soon as the update is available. :)

    Cheers,
    Ari.

  11. B_Dark
    Member
    Posted 1 year ago #

    the problem resolved with the last update(:)), but makes problems now with WP Smush.it NextGEN Gallery Integration, its shows a empty white page when you try to manage someone gallery :/

  12. Mike
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @nickth

    One of our developers has just taken over this project and yesterday he released version 1.6.5.1 which included quite a few improvements, one of which addresses various errors.

    Do you think you could try the latest version and let us know how you get on?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.