WordPress.org

Ready to get started?Download WordPress

Forums

"HTTP error" when uploading mp3 files on 3.5.1 (29 posts)

  1. joepayne4
    Member
    Posted 1 year ago #

    Until recently, I have been able to upload files up to 150 MB (customized PHP.ini settings). Now, if I upload an mp3 file I receive an "HTTP error" once the file is finished uploading. I am still able to use the Media Uploader to upload smaller .png files.

    I checked the compatibility of my theme, and it was tested up to version 3.3. I switched to the Twenty-Eleven theme, and still encountered the same problem.

    My site is hosted on Bluehost, and I have sent two separate requests for assistance to them that have received answers that weren't helpful at all.

  2. theotherlebowski
    Member
    Posted 1 year ago #

    you do know that wordpress is now on 3.5.1 don't you? 3.3 was quite a while ago in development cycle time...

    upgrade to the latest version, upgrade your plugins, upgrade your theme and ten see if the problem persists...

  3. joepayne4
    Member
    Posted 1 year ago #

    Thanks, but yes, that's why I listed 3.5.1 in the title post. I have the latest version, and all of my plug-ins are updated. The Absolum theme that I am using was tested only to 3.3, so that's why I tried a different theme (which gave the same results).

  4. theotherlebowski
    Member
    Posted 1 year ago #

    can you give us a list of the plugins you're using?

  5. joepayne4
    Member
    Posted 1 year ago #

    1 Flash Gallery
    AddThis Social Bookmarking Widget
    Akismet
    Audio Player
    BackWPup
    Fast Secure Contact Form
    Front-end Editor
    Jetpack by WordPress.com
    Ultimate TinyMCE
    Wiziapp
    Youversion

  6. theotherlebowski
    Member
    Posted 1 year ago #

    thurn off Front-end Editor, Audio Player and Youversion (not been updated since 2008 and is no longer supported!) as they're not compatible with wp 3.5.1. if you can delete them too so that they can't do anything in the background and see if that helps.

  7. joepayne4
    Member
    Posted 1 year ago #

    No luck. I deleted those plugins, and uploaded a 70 MB mp3 file. The file uploaded, and then displayed "HTTP error" with no other information.

  8. r2fidelis
    Member
    Posted 1 year ago #

    I have been experiencing the same issue. Have you got any further on solving this issue?

  9. jholder83864
    Member
    Posted 1 year ago #

    We really need to look at the log. The HTTP error is only sent to the client, but your error log should have more information on why the server sent an error to the client.

  10. joepayne4
    Member
    Posted 1 year ago #

    No, r2fidellis, the problem is unresolved. From searching here, it appears that there are a lot of people who have/are experiencing some variation of this.

    jholder83864, I just tried a new upload (failed) in order to get a current error to show on the log. But...I don't know how to find the error log. I'm on Bluehost, and the "Error Logs" available through my CPanel show errors across the entire server (with no search function to find just my IP). The SUEXEC error_log lists nothing, and the PHP error_log lists nothing current.

  11. r2fidelis
    Member
    Posted 1 year ago #

    My problem was the own audio plugin i was using. Changed it and everything is working fine now. (:

  12. Paalomino
    Member
    Posted 1 year ago #

    I am having the same problem. I'm using WP 3.5.1 / Clean Retina WP Theme, have disabled all audio plugins. I'm only using: "Comment Disable Master" plugin.

    The php.ini file has been adjusted to a maximum file size of 500MB. I have successfully uploaded four other MP3 files using the multi-file uploader, but the last one, a 76MB file goes through the upload process, (have tried both the multi-file uploader and the browser uploader) then at the end, the "HTTP Error" message appears.

    I have contacted Bluehost and they referred me to WordPress.

    Here's hoping someone here can suggest a solution.

    Thanks in advance for any assistance.

  13. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Compress file(s)...76MB is a full CD (not a single file...goodness...hows the bandwidth usage going?)...Also ask host if it blocks content uploads with known Copyright (they do, but rarely the CSR knows the issue)

  14. theotherlebowski
    Member
    Posted 1 year ago #

    try disabling that plugin too, it's not been updated in nearly a year and is only compatible up to wp 3.3.2

  15. Paalomino
    Member
    Posted 1 year ago #

    I disabled the "Comment Disable Master" plugin, but the upload still results in an "HTTP error" message. The other three audio files are between 30MB and 50MB, so will edit this larger file into two smaller sections and see if that works. I don't think there are copyright issues, these are original files, but will investigate this.

    Thanks for suggested solutions.

  16. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Check your media library. I think you will find the file did indeed upload.

  17. Paalomino
    Member
    Posted 1 year ago #

    I always check the media library after an upload, as a matter of course, and the file isn't there, unfortunately.

  18. joepayne4
    Member
    Posted 1 year ago #

    Ditto, Paalomino. They're never in the media library. I've also done all of the plug-in checks as well. They are also original files, and there is no copyright issue.

  19. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I have gotten that error a few times but it stopped. I change my site a lot so I don't know what I did. After trying to upload again a couple of times, the next time I go back to wordpress and the media library I find three copies of the image. So for me clearing the cache showed the image.

    You also should try deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). You also can try resetting the plugins folder by FTP or PhpMyAdmin (read http://bit.ly/UhpkLl if you need help). Sometimes, an apparently inactive plugin can still cause problems. Also try switching to the Twenty Eleven theme to rule out any theme-specific problems.

  20. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    @Paalomino
    You might want to try direct theme support here http://wordpress.org/support/theme/clean-retina/page/2

    And it is better to start your own thread per forum rules, http://codex.wordpress.org/Forum_Welcome#Where_To_Post and to post a link to your site.

  21. Paalomino
    Member
    Posted 1 year ago #

    Thanks kmessinger. I have deleted all plugins, switched the theme to Twenty-Twelve, and tried again. Still not working. The MP3 is apparently uploading entirely (100%), but am still getting an error message. This time I got the following:

    "500 Server Error. A misconfiguration on the server just caused a hiccup. Check the server logs, fix the problem, then try again."

    The URL I'm working on is: http://edfrankel.com/newsite/

    I will now look at the the other links you've referred me to, will check out the forum rules specifically, and start a new thread for this. Also, thanks for suggesting that I check out Clear Retina Theme forum, I'll do that too.

  22. cmfranklin
    Member
    Posted 1 year ago #

    about audio/mp3's I have a limit of 8mb's why do I have this limit? And I'm also having problems uploading a 6mb mp3 file...It keeps giving me errors, haven't successfully uploaded one yet. Trying no plugins activated and the regular uploader, see if that works.

  23. cmfranklin
    Member
    Posted 1 year ago #

    Ok, so i tried to upload it this way and I got internal error 500 code.

  24. theotherlebowski
    Member
    Posted 1 year ago #

    if you're getting internal 500 errors then there's "something" wrong on the server. it might be something you can fix or it might be a major issue that the server management company will have to address. you'll have certain limits on what you can do, how much you can upload, how big the filescan be etc imposed by your hosting company and their usage policies...

  25. cmfranklin
    Member
    Posted 1 year ago #

    ah, ok great thanks so much, I didn't know if it was WP or server, so now I'll go to them.

  26. cmfranklin
    Member
    Posted 1 year ago #

    well according to provider...I have a windows server, and wordpress works better on linux.

  27. NEDFiles
    Member
    Posted 1 year ago #

    I just updated my php.ini file to increase my max upload file size to 500 and now I"m getting this error to. It loads all the way to 100% then says HTTP ERROR instead of finishing. Smaller files load fine still.

    Has anyone been able to find a fix?

    I'm using the Suffusion theme and WP 3.5.1

  28. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    @NEDfiles
    Please start your own post per the forum welcome.

  29. PhilMeadows
    Member
    Posted 7 months ago #

    If you're confident you PHP.ini settings are cool, it could be the apache mod_fcgid module.

    My error log read,
    "mod_fcgid: HTTP request length 16779071 (so far) exceeds MaxRequestLen (16777216)"

    I've emailed my host about increasing this value.

Topic Closed

This topic has been closed to new replies.

About this Topic