WordPress.org

Ready to get started?Download WordPress

Forums

Delightful Downloads
[resolved] HTTP Error when uploading files from computer. (7 posts)

  1. xtranhu
    Member
    Posted 1 year ago #

    Whenever I try to upload a file from my computer (with any extension), this error shows up: "HTTP error." As long as the file has more than ~1Mb it fails.
    Some small images pass trough tough. Its the weirdest thing.
    I can't pin point the origin of this error due to the lack of information.

    My php.ini is set accordingly and ready for attachments bigger than 25 Mb.

    Any help would be appreciated.
    Thanks

    http://wordpress.org/extend/plugins/delightful-downloads/

  2. A5hleyRich
    Member
    Plugin Author

    Posted 1 year ago #

    That is very strange. Does your server log show any error messages?

    Also, what do you have the following set to in php.ini? max_execution_time, max_input_time, memory_limit & upload_max_filesize

  3. xtranhu
    Member
    Posted 1 year ago #

    What do you mean by server log?

    In WP debug log nothing shows up.

    My php.ini is set with:
    max_execution_time=120
    max_input_time=120
    memory_limit=-1
    upload_max_filesize=25M

  4. A5hleyRich
    Member
    Plugin Author

    Posted 1 year ago #

    You should be able to see your server log file under your hosting provider's control panel. The log should give us more information as to why the uploads are failing.

    Ashley

  5. xtranhu
    Member
    Posted 1 year ago #

    I use my own dedicated server with nginx. No control panel. I guess I could debug nginx but last time I checked debugging in ngix had to be enabled when compiled.

  6. xtranhu
    Member
    Posted 1 year ago #

    Ok, I figured it out.

    There was something bugging me about the file size and only now I realised that nginx disregards php.ini values if you dont specify a larger value on vhost.

    Just added "client_max_body_size 100M;" to my nginx default.conf (under server) and now it's working.

    Nothing to do with the plugin.

    Thanks for the support tough ;)

  7. A5hleyRich
    Member
    Plugin Author

    Posted 1 year ago #

    Glad you figured it out and thanks for the positive feedback.

    Ashley

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic