WordPress.org

Ready to get started?Download WordPress

Forums

HTTP Error uploading images message, but still uploading images but with no data (10 posts)

  1. masok88
    Member
    Posted 1 year ago #

    I just got a new hosting account and did a one-click install of the latest version of wordpress.

    I enabled thumbnails and added a featured image to my posts except when I upload images I get a HTTP Error message coming up however when I then go and check the Media library their is an image their, I can link to it etc. however when I go to edit the image it cannot edit the image as 'Image data does not exist. Please re-upload the image'.

    I've looked at a few different solutions, I'm only using two plugins. 'Ambrosite Next/Previous Post Link Plus' and 'Disqus Comment System' both of which I've toggled to check if it was them.

    Any help would be amazing. Its driving me mental at the moment.

  2. riversatile
    Member
    Posted 1 year ago #

    Using your FTP browser (Filezilla...), did you check the folder permissions of the uploads folder in wp-content ???
    Minimum is : 755
    Maximum : 777

  3. masok88
    Member
    Posted 1 year ago #

    Hi,

    Yes I had, they were all set to the correct permissions. I'd already switched it to 777.

  4. riversatile
    Member
    Posted 1 year ago #

    Did you try this solution ?
    WordPress HTTP Error crunching .htaccess

    For some reasons and depending your web server provider, this change may be needed.

  5. masok88
    Member
    Posted 1 year ago #

    I did the change already but did so again, when I went to media library 'add new' and hit upload the page crashed and I got the message..

    'The webpage at http://myurlhere.com/wp-admin/media-upload.php?type=image&tab=type&post_id=0 is currently unavailable. It may be overloaded or down for maintenance.'

    This occurs even if I revert the changes to .htaccess

  6. riversatile
    Member
    Posted 1 year ago #

    OK.

    Did you try to upload a very very small JPG file (for example : 16x16 px) with a very very little file size ?

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    The most common reason for this is an overly-zealous configuration of mod_security on your server. Have you spoken to your hosts about it?

  8. masok88
    Member
    Posted 1 year ago #

    I was uploading moderately sized images and those and anything upwards were causing the errors. I uploaded a 50x50 white square no problem. I think the biggest I've managed to upload is 4kb

  9. masok88
    Member
    Posted 1 year ago #

    I'll send my hosts a message in the mean time too.

  10. masok88
    Member
    Posted 1 year ago #

    Hi everyone,

    I've been following the ticket opened with my hosting company Eleven2 and the latest response I'd gotten from them was..

    'This is a compatibility issue between litespeed and wordpress. You will have to manually downgrade the wordpress.'

    Which is really disappointing, as esmi pointed out it sounds like a service issue rather than one with the setup/install. I'm not even sure what litespeed is but I've seen it pop up on my site when theirs been downtime (already in the first three weeks of having the account!).

Topic Closed

This topic has been closed to new replies.

About this Topic