WordPress.org

Ready to get started?Download WordPress

Forums

HTTP Error - This is getting ridiculous (9 posts)

  1. martino180
    Member
    Posted 4 years ago #

    Ok I've searched for DAYS in search for a solution to this.

    I've tried EVERY .htaccess addtion (even though i DO NOT HAVE the file) I've created it and added the coding everyone has suggested.

    Downloaded multiple plugins

    Tried every possible trick that has come up by searching and I'm VERY fed up with the issue.

    I'm having no problems uploading smaller sized files however as soon as I try to upload say a 1.8mb image I get the famous HTTP Error.

    I need this fixed asappppp

    Blog: http://www.visualsugar.com

    Thanks,

    Mike

  2. Robert S
    Member
    Posted 4 years ago #

    A pull the hair out job! It's those WP issues that take "days" to solve that become a means to learning!

    Your issue would appear to be related to limits set by your PHP configuration. You will need to "delve" into the PHP.INI file and play with the following setting:

    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 8M

    The default setting is 2Mb. Change this to whatever you like - I have my max upload size set to 8Mb.

    How you go about changing this setting in PHP.INI will depend on who you hosts with. I'm with Bluehost and am able to tweak my PHP settings.

    R

  3. R's right: That's what the problem will be and you can check by making a phpinfo() file and reading the settings that way.

    Create a file phpinfo.php file and upload it to your blog:

    <?php
    phpinfo();
    ?>

    Load that file via http://your-blog-info/phpinfo.php and search for upload_max_filesize. As R said that's probably set to the default size.

    Get that changed and you should be good to go.

  4. martino180
    Member
    Posted 4 years ago #

    Thank you both for the replys.

    I just took a look at the file and it's set at 64M. I've also created that phpinfo file and the upload_max_filesize said 20M

    So I'm still not sure what my issue here is.

    Do picuture dimensions have anything to do with the HTTP Error as well? The photo I'm trying to upload is 1.8MB @ 3065 × 2163. It's a full resolution photo. Now obviously I can go and edit it to be smaller however I have editors who are not so capable which in term I'd prefer it to be "uploadable" thus making it easy for my editors to play around with it in the post.

  5. doc4
    Member
    Posted 4 years ago #

    martino180,

    The image wouldn't happen to be 300dpi would it? This could be causing some problems at these dimensions.

  6. bookchiq
    Member
    Posted 4 years ago #

    cosmictap posted a link that solved the "HTTP error." problem for me (after all other solutions I tried failed).

    Just for the record, I am using WP 2.9 on HostGator.

  7. recus
    Member
    Posted 4 years ago #

    I'm still experiencing this problem. It has nothing to do with my .htaccess for sure. Anyone know the solution?

  8. Samuel B
    moderator
    Posted 4 years ago #

    rschilt & jdembowski
    posted the solution above

  9. scottbothel
    Member
    Posted 4 years ago #

    I ended up needing to boost max_post_size and max_exec_time as well... I hope it helps!

Topic Closed

This topic has been closed to new replies.

About this Topic