WordPress.org

Ready to get started?Download WordPress

Forums

Co-Authors Plus
"HTTP Error" on Media after upgrade WP 3.5 (22 posts)

  1. B_Dark
    Member
    Posted 1 year ago #

    I have problems with plugin and wordpress 3.5 multisite. I got "HTTP Error" when I upload images via WP Admin > Media Library > New or via Posts>Add New Post>Add Media.

    The problem is with the dispossession of images.. specific any photo over than 511(width) i got http error , and any image less than 511(width) upload without any http error

    plz fix asap!!

    http://wordpress.org/extend/plugins/co-authors-plus/

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    Does the problem persist when you've deactivated the plugin?

  3. B_Dark
    Member
    Posted 1 year ago #

    no

  4. B_Dark
    Member
    Posted 1 year ago #

    why resolved? where is the solution?

  5. B_Dark
    Member
    Posted 1 year ago #

    i deactivated all of my plugins again and i found this:

    My custom theme says "http error" without the plugins activated, also when Co-Authors Plus (Version 3.0.3) is activated with another theme (Twenty Twelve) it still says "http error" when i upload an image via media or post

  6. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    Odd. Is it all photos or just some photos? Can you share some examples I can try? Who is your webhost?

  7. B_Dark
    Member
    Posted 1 year ago #

    the problem is with the dispossession of images.. specific any photo over than 511(width) i got http error , and any image less than 511(width) upload without any http error.

  8. B_Dark
    Member
    Posted 1 year ago #

    with wp 3.4.2 i don't have any problem , only with wp 3.5

  9. B_Dark
    Member
    Posted 1 year ago #

    Have you tried it latest version of wp? Did you had the same problem? If yes, what is causing this problem wp 3.5?

  10. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    Yes, I've tested with the latest version of WordPress and can't reproduce. Considering there haven't been any other reports of this, I suspect it's a problem specific to your install.

  11. zhivenkoff
    Member
    Posted 1 year ago #

    hi

    after upgrade im have same problem

    have .jpg file, 445 KB - HTTP Error

    im change this file to .png, other format - have problem too

    other file upload good

    im upload this file other blog, old version - not have problem too

    only in 3.5

  12. B_Dark
    Member
    Posted 1 year ago #

    @zhivenkoff try this test

    the problem is with the dispossession of images.. specific any photo over than 511(width) i got http error , and any image less than 511(width) upload without any http error.

    i don't thing is the file sizes but the dispossession of images

  13. B_Dark
    Member
    Posted 1 year ago #

    Ok, since we start from there lets take it all from the beginning .

    When I still had the wp multisite at 3.4.2 version I didn't had this issue. The site was working without any "http error" when I was uploading a photo through media or post/page.

    After the update to 3.5 version it started giving http errors. I tried with with all the plugins deactivated and having activated only my premium theme. It kept having http errors, so I decided later to deactivate the premium theme and activate Twenty Twelve theme. It didn't have any errors while I was uploading photos while all the plugins where deactivated. I decided after that to activate one by one the plugins and upload a photo everytime, when I activated Co-Authors Plus (Version 3.0.3) (while still having Twenty Twelve theme on) it showed an http error when I was uploading a photo. I started uploading many photo sizes, at first I thought that it uploads without any http error those that were smaller in size.
    So, I compressed to a smaller size photos with big dimensions and it kept having http error. So I decided to upload photos with different dimensions and I saw the problem is with the dispossession of images.. specific any photo over than 511(width) i got http error , and any image uploaded less than 511(width) didn't had any http error.

    So with simple logic thinking, the premium theme and the plugin have incompatibility with wordpress 3.5 with the photo dimensions when you are uploading.

  14. B_Dark
    Member
    Posted 1 year ago #

    Also, I tried it only with CoAuthor plugin on Twenty Twelve and on my premium theme and I had again http error.

  15. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    From this thread, it sounds like you might be having memory issues with your host. Co-Authors Plus registered four additional image sizes that you can disable with this:

    add_filter( 'coauthors_guest_author_avatar_sizes', 'dbx_avatar_sizes' );
    function dbx_avatar_sizes() {
        return array();
    }
  16. zhivenkoff
    Member
    Posted 1 year ago #

    memory 32 MB

  17. B_Dark
    Member
    Posted 1 year ago #

    @Daniel Bachhuber where i have to add this code?

  18. B_Dark
    Member
    Posted 1 year ago #

    my memory is 1024m

  19. awanxp
    Member
    Posted 1 year ago #

    Exactly. I have the same problem.. :(.
    I got the HTTP Error when uploading an image after i upgrade to wp 3.5.
    But the image uploaded even though the error persist.

    Anyone help me please...

  20. B_Dark
    Member
    Posted 1 year ago #

    the code you have give me before 3 weeks so, no solution with this code

  21. Just2host
    Member
    Posted 1 year ago #

    Hi

    I had the same problem when building a new server and transferred my WP sites across. I found in my logs that it was a apache error with PHP.
    mod_fcgid: HTTP request length 131100 (so far) exceeds MaxRequestLen.

    To Fix I added MaxRequestLen 15728640 which is 15MB to the following file
    /etc/apache2/mods-available/fcgid.conf and restarted apache.

    Hope this helps

  22. B_Dark
    Member
    Posted 1 year ago #

    @Daniel Bachhuber check this

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic