WordPress.org

Ready to get started?Download WordPress

Forums

HTTP Error on image upload - STILL (41 posts)

  1. jjphoto
    Member
    Posted 5 years ago #

    Hey everyone. I'm a relatively new WP user, and I'm running into that horrendous HTTP error on image upload. I have:

    1) read Otto42's article: http://wordpress.org/support/topic/164999
    2) deleted my wp-admin and wp-includes folders
    3) downloaded a fresh copy of WP 2.8.2
    4) uploaded the deleted directories fresh
    5) changed permissions on my wp-content/uploads folder to 755, and then to 777 just to see if it helps
    6) ensured that my Settings-Misc "store uploads" field is set to the default.
    7) created an .htaccess file with the mod-security fix language in it and uploaded it to my domain root, the WP root, and the wp-admin directory.
    8) set the permissions for the .htaccess files above to both 755 and 777
    9) recreated the same problem in IE, FF, and Chrome.
    10) ensured that I have the latest Flash and Shockwave installed.
    11) tried uploading smaller images
    12) deleted my "uploads" folder, removed all entries from the Media Library, and tried a brand new upload.
    99) sacrificed a few chickens for good measure.

    Is there ANYTHING else that could be causing this problem?

    To throw a monkey wrench into your thought process, I have 2 blogs on 2 domains, both hosted on the same server - only 1 of them has this problem...

    I'm going insane here...

  2. salaknib
    Member
    Posted 5 years ago #

    Same problem here!

    All three blogs that I work on have the same issue. For the first one, it was a theme error. I added <?php wp_footer(); ?> to footer.php For the second one, it was flash. I added a swfupload_f9 file to the js folder. Both worked. Now I have the same problem with another blog and nothing seems to work! Help!

  3. ahhstudios
    Member
    Posted 5 years ago #

    I had the same issue although it was after I transferred my blog to a new hosting provider. Try this-
    Go to your Settings tab and then to Miscellaneous Settings. There is a place there for "Store uploads in this folder"- check to make sure that that makes sense. It should be just "wp-content/uploads"- just like it suggests. This is what was the issue for me. Hope it helps you as well.

  4. slightner
    Member
    Posted 5 years ago #

    I have a similar problem, which occurred out of the blue about 4 weeks ago. First I got the HTTP error after the upload was "crunching". The photo was still there I could insert it although it was full sized and I could not decrease and since "crunching" apparently did not reduce it size, it took longer to display. When inserting it, I would have to reduce it four times to get it to a reasonable size and no caption information is available. Then the flash uploader stopped allowing me to browse for the photo to upload on my computer. If I used the browser uploader, it gave me a server error. I loaded WordPress 2.8.2 yesterday and I still have the same problem, although my flash uploader will now browse my files. I inserted the security code in the htaccess file and changed the permissions to 777 with no change. Note that I get the same problem if I use a Mac or a PC and using Firefox, Safari, IE. If anyone out there has a clue how to fix this, I would be ever so grateful.

  5. jjphoto
    Member
    Posted 5 years ago #

    OH MY GOODNESS! I FIXED IT!

    I could SWEAR that I've tried this before, but I deactivated a plugin I was using (Shared Items Post - Scheduled automatic posting of Google Reader Shared Items), and it works all-of-a-sudden!

  6. fyankai
    Member
    Posted 4 years ago #

    I had the same thing. Eventually realised my hosts were running PHP4 - changed to PHP5 and it fixed it. (Although now I've found that my hosts only assign 40MB of memory for PHP - which means I have to resize larger pics before upload, but at least I can upload!)

  7. liquidrice
    Member
    Posted 4 years ago #

    fyankai! Thanks so much!! That was exactly what it the problem was. luckily, its just my personal blog and i had only a month of posts. So I had no clue how to go from PHP4 to PHP5, I ended up just building a new db with PHP5 and imported from the old files.

  8. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Add this code in htaccess:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Now have a check.

    Shane G.

  9. esmi
    Forum Moderator
    Posted 4 years ago #

    I had an HTTP image issue the other day. The mod-security fix mentioned above didn't work and the image was 24bit/16 million colors. However Otto's note that problem could be with the image itself was spot-on. I copied the original png and re-saved it as a jpg. The image uploaded flawlessly. Since seen reports of same issue in similar images.

    So, if all else fails, try going back to the original source image, copy it and re-save in .jpg format.

  10. toddheitner
    Member
    Posted 4 years ago #

    I've been having this same issue and finally got it fixed. Since I spent a whole day trying to get this resolved, I'm going to post the solution that finally worked for me.

    Since some of the forum posts mentioned something about their host being involved, I decided to contact my host and see if they could figure it out and they did. I asked for details about what they changed so I could post it for other users.

    Here is what they said:

    "Modsecurity was blocking the useragent of the flash uploader. This is common. I disabled the block."

    When I asked for more details about where exactly they made this change, they said:

    "I simply removed the useragent block in /usr/local/apache/conf/modsec2.user.conf"

    Hopefully someone else will find this useful.

  11. JonRWilson
    Member
    Posted 4 years ago #

    If you're getting the image upload http error during crunching, I found this to solve the problem.

  12. cosmictap
    Member
    Posted 4 years ago #

    folks- take a look at this:
    http://wordpress.org/support/topic/280337?replies=19

    it solved my problem. (i had HTTP-auth on for the directory)

  13. webmanla.com
    Member
    Posted 4 years ago #

    had the same problem, fixed it only when upgrade to PHP5 hope this helps !

  14. bookchiq
    Member
    Posted 4 years ago #

    cosmictap's link solved the problem for me (after all other solutions I tried failed).

  15. jweasl
    Member
    Posted 4 years ago #

    Jon R Wilson you are my new favorite person. Worked like a charm!
    http://jonrwilson.com/blog/2009/12/wordpress-http-error-crunching-htaccess/

  16. siropel
    Member
    Posted 4 years ago #

    For those using 2.9 you can try this http://www.valipetcu.com/2010/01/how-to-fix-http-error-in-wordpress-2-9.html if everything else fails

  17. photoclasshero
    Member
    Posted 4 years ago #

    I'm using 1and1 for hosting and have been having this problem since I upgraded to 2.9. I was able to solve it today on 1and1 by changing the .htaccess in the wordpress installation folder to use php5 by default. I added this code at the top of the .htaccess file:

    AddType x-mapp-php5 .php

    It worked immediately. Even with all my plugins activated. Give this a shot if you are hosting with 1and1.

  18. amplifiedshock
    Member
    Posted 4 years ago #

    NONE of the above worked for me, except for this: http://www.ericm.ca/2010/web-development/wordpress-2-9-1-http-error

  19. CapitalC
    Member
    Posted 4 years ago #

    The problem in my case was none of the above -- it was the image itself. I'm not 100% sure what, but even goofing around with it in Photoshop several times resulted in a garbage JPG which simply wouldn't upload. Any other file would upload just fine.

  20. evelester
    Member
    Posted 4 years ago #

    I'm using 1and1 for hosting and have been having this problem since I upgraded to 2.9. I was able to solve it today on 1and1 by changing the .htaccess in the wordpress installation folder to use php5 by default. I added this code at the top of the .htaccess file:

    AddType x-mapp-php5 .php

    It worked immediately. Even with all my plugins activated. Give this a shot if you are hosting with 1and1.

    just wanted to confirm that this fixed the issue for me! Thanks so much, there are quite a few 1&1 wordpress issues so far, but I have been able to fix them all so far.

  21. maximumbeth
    Member
    Posted 4 years ago #

    This is killing me. I also have a 1&1 account and it seems like the .htaccess file solution is the perfect one, but I cannot for the life of me find the .htaccess file in my wordpress installation folder! I have it so hidden files are shown but it's still not there. I'm using permalinks (I think) so I don't think that's the problem...what am I doing?? Please help!!!

  22. JuryDuty
    Member
    Posted 4 years ago #

    I'm using 1and1 too and this line solved my problem, too!

    maximumbeth--it should be there in the root of your wordpress installation folder. I'm guessing your ftp program is hiding it as a hidden file or something?

  23. dbradley
    Member
    Posted 4 years ago #

    This might work. All the advice to update my htaccess was not helping. I run my blog on a windows server. This is how I fixed this HTTP error problem.

    With in your Dashboard go to Settings and then Miscellaneous Setting.

    For some reason my hosting site automatically added this to the Store upload files path.

    (/home/users/web/b2284/ipw.livingproofbc/nt/blog/wp-content/uploads)

    I deleted it all and replaced it with

    wp-content/uploads (just as recommend.) (Also make sure you have a uploads file in your wp-content folder)

    Now IT WORKS!

    This only took me 8 hours of tweaking to get it to work. Hope this works for you.

  24. jeanne38654
    Member
    Posted 4 years ago #

    photoclasshero
    Member
    Posted 3 months ago #

    I'm using 1and1 for hosting and have been having this problem since I upgraded to 2.9. I was able to solve it today on 1and1 by changing the .htaccess in the wordpress installation folder to use php5 by default. I added this code at the top of the .htaccess file:

    AddType x-mapp-php5 .php

    It worked immediately. Even with all my plugins activated. Give this a shot if you are hosting with 1and1.

    I am using 1 and 1 and this worked like a charm!!! :) Thanks!

  25. Ephazi
    Member
    Posted 4 years ago #

    @photoclasshero

    That did the trick.. No more HTTP ERRORS when uploading/crunching images. Friggin' Genious!!! I use 1and1 too and I think they suck!

  26. tomfroese
    Member
    Posted 4 years ago #

    Hello, I had a similar problem:

    - images smaller than approximately 640 x 480 would upload properly but I would get the "http error" message on image crunch with anything larger.

    I tried different variations of the .htaccess hack, but finally found Jon R. Wilson's to work! (I didn't even have to put the .htaccess file in higher-up directories, only in the root wordpress directory.

    My own setup is a PHP Version 5.2.13 server hosted by 1and1.com.

    Hope this helps someone else! Thanks Mr. Wilson.

  27. diecastfast
    Member
    Posted 4 years ago #

    More often than not, all you need to do is use the Browser Upoloader. The Browser Uploader worked perfectly fine for me after getting errors on the Flash Uploader.

  28. jasontremblay
    Member
    Posted 4 years ago #

    If you're using WPMU, you may be getting this error because of the "fileupload_maxk" setting in the "wp_sitemeta" table.

    Ok, if you're uploading big files, you may have changed the PHP ini settings so that you can upload files larger than the PHP default of 2MB -- as discussed here. However, it seems that WPMU enforces it's own separate file upload size limit. When using the browser uploader, you'll get an error that says:

    "This file is too big. Files must be less than 1500 Kb in size."

    But if you use the flash uploader, you get the dreaded "HTTP Error".

    Increasing the "fileupload_maxk" as detailed in this article made both errors go away for me :)

  29. Halibutt
    Member
    Posted 4 years ago #

    Shane G's method worked for me, thanks mate!
    Cheers

  30. cili
    Member
    Posted 4 years ago #

    I had this problem after upgrading to 3.0. Photoclasshero's method solved it.

    AddType x-mapp-php5 .php

    I'm using 1&1 and I added the above line at the top of my .htaccess in the root directory only and it fixed the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic