WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] HTTP Error on Image Upload-Crunching (11 posts)

  1. marenmisner
    Member
    Posted 4 years ago #

    Hello! I just installed WordPress 3.0 and am receiving the 'HTTP Error' when I upload images with the flash uploader. I tried using the basic uploader and receive the message 'Error 500 - Internal server error An internal server error has occured!
    Please try again later.'

    I have read pretty much every forum thread about various HTTP errors while uploading images, and have tried all the fixes, but none have worked so far. I do not have an .htaccess file, so I created one in TextEdit, inserted the code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    (as instructed on http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks)

    I saved this as .htaccess, uploaded via FTP, and then I loses access to my site (and am given the 'Error 500- Internal Server Error message).

    I have manipulated the code various ways as instructed on different forums, but none fix the problem. (AddType x-mapp-php5 .php) (AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php) (SecFilterEngine Off SecFilterScanPOST Off)

    When I delete the .htaccess file I can get into my site again, but then of course I am back to my original problem of the HTTP Error while uploading images.

    I use 1and1 and they are running MySQL 5. (And I use Mac OSX 10.4.11 if that matters at all!)

    I am wondering if I need to edit something in the .htaccess file? (I know absolutely nothing about this or its function.) My site is http://www.marenmisner.com/wordpress -does it matter that it is not my index page? (I don't think, anyway.) Please help!! Thanks!

  2. marenmisner
    Member
    Posted 4 years ago #

    1and1 fixed the problem! The .htaccess code needed was:
    AddType x-mapp-php5 .php .php4

    So I had been missing the '4' off the end of the code. After I emailed support, they got back to me within 30 minutes and fixed it. Very pleased with their customer service. Photos are uploading correctly!

  3. schmuy
    Member
    Posted 4 years ago #

    Thanks! This fixed my problem too

  4. marenmisner
    Member
    Posted 4 years ago #

    Glad to hear!

  5. jeanne38654
    Member
    Posted 4 years ago #

    I am having this problem and I am also with 1 and 1. I had this problem previously on another site and had added the .htaccess file (just like in your OP) and all was good. This is NOT working now. I guess I need to add the AddType x-mapp-php5 .php .php4 line, but where to add it? I will test it and post back. I think others would find it helpful to see the exactly what that .ht file should look like.

  6. jeanne38654
    Member
    Posted 4 years ago #

    Ok, not sure if it really matters WHERE (you originally said end of file so that's what I did) - AND IT WORKED :)

    So for anyone else looking around, here's my .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    AddType x-mapp-php5 .php .php4

    YAY!!! :) THANK YOU SO MUCH!! :)

  7. Tina_H
    Member
    Posted 4 years ago #

    Thanks so much for this, you saved me going mad on a Monday morning!!

  8. vonkanehoffen
    Member
    Posted 4 years ago #

    Another thing that can interfere with the flash uploader is password protection, ie. if you have something like:

    AuthType Basic
    Require valid-user
    etc etc...

    in your .htaccess file.
    Had my site on a testing server and was wondering what was going on here for ages!
    Hope that helps someone.

  9. jasonrichek
    Member
    Posted 3 years ago #

    I use 1and1 also and that totally worked!!! Thank you for posting this!!!

  10. taiwanho
    Member
    Posted 3 years ago #

    I had this problem and turning safe mode off worked for me. Just another option if the htaccess solution doesn't work for you.

  11. Mouthsmasher
    Member
    Posted 3 years ago #

    Wow, this was a HUGE help! I also have 1and1 as my hosting service and have had the same problem uploading images.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic