WordPress.org

Ready to get started?Download WordPress

Forums

http error image upload (32 posts)

  1. haavadb
    Member
    Posted 6 years ago #

    Hi!

    I get this error on every attempt to upload an image. I´ve tried several images, various browsers and different machines. The same error occurs every time...

    The tips in the sticky post do not seem to solve the problem...

    The message I get is:
    HTTP ERROR
    crunching
    An error occured in the upload. please try again later.

    What would cause such an error, and how can I resolve it?

  2. bsweber
    Member
    Posted 6 years ago #

    I've got the same error happening. I just switched to 2.5 a few days ago.

  3. raffo
    Member
    Posted 6 years ago #

    any news?

    it's a big bug... possible that noone has fixed it??? :(

  4. super rats
    Member
    Posted 6 years ago #

    It doesn't seem to like larger files. One image was a 194k jpg and I got this error. Smaller images upload fine for me.

  5. simcomedia
    Member
    Posted 6 years ago #

    I have this problem also. I've tried tiny files and large files. Same results. Exact same error over and over on the crunching part.

    Anyone have a real idea on this issue?

  6. onedeep
    Member
    Posted 6 years ago #

    I have run into the same error, but only using Firefox. When in IE, I get a completely different error, but the image actually successfully uploads.

    Unfortunately, I cannot manipulate that file in IE, but if I switch back over to FF, it sees the image and is perfectly content to mess with it.

    This tells me that it is definitely a WP2.5 issue, and not something with folder permissions, file sizes, or config.

    I have also seen many people have this issue, but I have yet to see a solution presented that works (other than the one I use right now) either officially or unofficially.

  7. bpolhemus
    Member
    Posted 6 years ago #

    Anyone tried using Safari? I don't use Safari much despite installing it (at Apple's insistence) on my Windows XP laptop, but it's a though.

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Have you gone through the various fixes listed here?
    http://wordpress.org/support/topic/164999

  9. trex33
    Member
    Posted 6 years ago #

    May want to check out my recent post on mod_security and flash

  10. onedeep
    Member
    Posted 6 years ago #

    I have tried every single one of those fixes.

    The main problem is that they actually seem to work. For instance, I put in this one a couple of days ago:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Uploads worked fine. Now today, they are no longer working. This has happened with at least half of the fixes I have tried (and all of them that have to do with .htaccess). The other half just didn't do anything.

    The only one I haven't tried - and have been avoiding - is the no flash uploader plugin. It seems silly to me that I have to turn off half of a feature of 2.5 just to get the rest of it to work.

    What is worse is that it appears to me that the WP folks who can fix it aren't doing anything to fix it. Any time someone complains about this problem, people point to the same post you pointed me to, but never say "its being worked on" or point to the ticket in the bug tracker.

    From what I am seeing on this message board, this is a consistent, persistent problem across multiple installs on multiple architectures using multiple browsers. It is a real problem that tweaking .htaccess or turning off (or on) plugins is only putting a band aid on.

  11. fishnyc
    Member
    Posted 6 years ago #

    I just installed a clean install and can't upload as well. Looked all over the message boards and tried ALL solutions. Any ideas what to do next?

  12. webwisedesign
    Member
    Posted 6 years ago #

    Added the .htaccess file to the wp-admin directory. The

    HTTP ERROR
    crunching
    An error occured in the upload. please try again later.

    Changed to

    Unable to create directory /home/mysite/public_html/wp-content/uploads/2008/04. Is its parent directory writable by the server?

    And, Yes, the parent directory is writable by the server (755).

  13. raffo
    Member
    Posted 6 years ago #

    just a big BUG of wp2.5...

    hope they can solve...

    my solution, is to use nextgen gallery plugin

  14. fultonfence
    Member
    Posted 6 years ago #

    i had this same issue and error for uploading photos, mp3s and videos - but changing the mod_security settings solved it.

    thanks

  15. Blooper1a
    Member
    Posted 6 years ago #

    same issue with 2.5.1

    apply mod_security to solve the issue

  16. jeremycherfas
    Member
    Posted 6 years ago #

    Mod security did not work for me.

  17. fransgaard
    Member
    Posted 6 years ago #

    Hi I had the same error with an older version of wordpress. From one day to the other it just stopped allowing me to upload images and I got this error:

    Unable to create directory /customers/fransgaard.eu/fr
    ansgaard.eu/httpd.www//../../../../../../../../../../..
    /../../../../../../tmp. Is its parent directory
    writable by the server?

    I thought it was the hosting company's fault but they can't seem to find anything on their side, so I upgrade to the latest verison of wordpress.

    This didn't solve the problem either. I can still post but unfortunately I still cannot upload photos, the error has change to just say "HTTP ERROR" now.

    Does anybody know a solution to this?

  18. alony
    Member
    Posted 6 years ago #

    Same problem with me. Clean install, tried doing the fixes, no change.

  19. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The ../../.. thing means that you have been hacked.

    Search the forums here for that sort of thing. Restore your database from a backup if you have one.

  20. fransgaard
    Member
    Posted 6 years ago #

    hacked?

    ><

    hmmm I don't have a backup of database, but everything I have posted up until now is still showing. Do I still need to wipe database?

    Will search the forum now. Thanks

  21. cperabo
    Member
    Posted 6 years ago #

    I tried both IE6 and Firefox and have the same problem. I have used FileZilla to load the images and then just picked them from the URL. Not the cleanest, but it works... now I just have to figure out how to do Thumbnails...

    Update: it works!
    This solution worked for me:
    http://www.hongkiat.com/blog/wordpress-25-image-upload-error-wordpress-fix/

    I tried big files, small files, wide files, Firefox, IE6, Changing permissions... nothing. But changing the .htaccess code worked.

  22. webwisedesign
    Member
    Posted 6 years ago #

    Otto, for the fixes you suggested at http://wordpress.org/support/topic/164999 what is the correct thing to do if the mod_security is causing problems?

    6. mod_security might be causing problems. Disable it to see if that is the problem.

    This worked for me but now don't I have a security issue?

  23. radartowers
    Member
    Posted 6 years ago #

    I am having the same problem since I upgraded - or maybe not quite the same. The error I am getting is:

    From Computer
    HTTP error.

    The file I'm uploading at the moment is only 8K. The only plugins I'm running are TinyMCEAdvance, Backup WordPress, Events Calendar, WordPress Automatic Upgrade.

    The Hongkiat.com solution doesn't work for me, and anyway, it seems like there might be security issues ... Anyone have any ideas? At the moment I'm using FTP to upload images, which is a right pain!

  24. radartowers
    Member
    Posted 6 years ago #

    So, I think for the moment, as Raffo says, is to use the Nextgen Gallery. Which is fine for me because I'll now be using this awesome plugin!

  25. iamthechosenone
    Member
    Posted 6 years ago #

    I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting "http error", but I know some people got "crunching" instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match "^Shockwave Flash" at HEADER("USER-AGENT") [id "***MY ID"][rev "1"] [msg "SpamBot UA"] [severity "CRITICAL"] [hostname "***MY-DOMAIN***"] [uri "/testing/blog/wp-admin/async-upload.php"]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

  26. iamthechosenone
    Member
    Posted 6 years ago #

    let me know the outcome. dave@isnigh.com

  27. jmanpa
    Member
    Posted 6 years ago #

    I had the "Http error".

    Before you waste time on all the fixes suggested, try the same upload from IE. I was using Firefox and switching to IE remedied my issue.

    That said, there seems to be a fix needed for Firefox ...

  28. webwisedesign
    Member
    Posted 6 years ago #

    iamthechosenone, The sites we are having difficulty with are also on HostGator. Thanks for the information! It is good to know that the hosting configuration can be change to fix this issue.

  29. ebizwildfire
    Member
    Posted 6 years ago #

    I'm still getting the http error when trying to upload media.

    I went here BUT THERE Are no instructions that I can see.

    http://trac.wordpress.org/ticket/6443

    How can we easily fix this?

    I see the htaccess suggestion above but the instructions are not
    detailed enough for a non expert, a few missing steps...

    Help please.
    Thanks
    D

  30. cusoon
    Member
    Posted 5 years ago #

    I have Same problem, too. Whats the solution?

Topic Closed

This topic has been closed to new replies.

About this Topic