WordPress.org

Ready to get started?Download WordPress

Forums

http error and 404 error on file upload (6 posts)

  1. connorjones13
    Member
    Posted 8 months ago #

    Alright, I'll try to keep a cool head when discussing this issue, but I have already tried about 3 dozen "solutions" that have not yet fixed the problem.

    Problem:
    So, uploading any files, be it themes, images, or anything, I receive a http error or get redirected to a 404 page whenever the file size is greater than 100kb... yes, kb.

    Info about hosting and what have you:
    Linux VPS
    PHP version: 5.3.19
    MySQL: 5.0.96
    PHP memory_limit is set to 32M
    upload_max_filesize is set to 100M

    .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Added the following line to wp-config.php(have tried without this as well):


    define('WP_MEMORY_LIMIT', '64M');

    Have also tried many changes to the .htaccess and php.ini files. These changes were related to establishing higher memory limits and upload limits. I have since reverted all changes to these files. Of course all plugins and themes were disabled during the process of troubleshooting. Upload speed is not an issue for those thinking it may be related to a max execution time problem.

    *Side note: files will upload to 100% and then the http error occurs when it begins to crunch the file. 404 page is generated when using the browser uploader as opposed to the multi-file uploader.

    All advice is welcome to help solve this issue.

    Thanks,

    Connor

  2. Tara
    Member
    Posted 8 months ago #

    does your server restricts file zize to 100kb?

  3. connorjones13
    Member
    Posted 8 months ago #

    I was under the impression that the following line:

    upload_max_filesize is set to 100M

    means that the file size is restricted to 100M.

    Also, there are a few other websites hosted on this same VPS and I can upload files to those that are multiple gigabytes with no problem.

  4. connorjones13
    Member
    Posted 8 months ago #

    If this were a mod_security issue what would I ask of my host? I have tried to override mod_security with the following code in the .htaccess to no avail:


    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

  5. connorjones13
    Member
    Posted 8 months ago #

    This is the error that I get in my cPanel error log:

    [Fri Nov 08 07:47:09 2013] [error] [client xx.xx.xx.xx] PHP: syntax error, unexpected '(' in /home/xxxxxxx/public_html/xxxxxxxxxxx/wp-admin/php.ini on line 1, referer: http:/xxxxxxxxxxxxxxxx/wp-admin/media-new.php

    There is currently not even a php.ini file in the website folders. One did not exist after I installed WordPress.

  6. esmi
    Forum Moderator
    Posted 8 months ago #

    I would suggest that you contact your hosts with a copy of that error message.

Reply

You must log in to post.

About this Topic