WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
[resolved] HTTP Error (19 posts)

  1. shelleyh
    Member
    Posted 2 months ago #

    I wanted to report that I have been having several issues getting HTTP errors (ironically only with one user, not all the users) when uploading images.

    Screenshot

    I was able to pin the issue down to this plugin since it works when deactivated. After getting the HTTP error the image would still seem to show up in the media library:

    Screenshot

    I've deactivated the plugin for now and can live without it, but I wanted to at least find out if this was a known issue or not.

    https://wordpress.org/plugins/wp-smushit/

  2. semester3
    Member
    Posted 2 months ago #

    I am getting the same exact issue above.

    However, mine is affecting all users.

    3 browsers on 2 Os's

    WP 3.9

  3. dmiyares
    Member
    Posted 2 months ago #

    Seems to be an issue today with the other end. Turned it off to get things posted in seconds. turned it back on and taking 5 - 10 mins for a 10k image!

  4. ShawnLunny
    Member
    Posted 2 months ago #

    We also had this issue. I think there is a larger underlying issue with WordPress 3.9 here. Looks like its been on and off issue for a couple weeks when i look in our image library.

  5. Chuck Reynolds
    Member
    Posted 2 months ago #

    Same issue on multiple sites.

  6. greencode
    Member
    Posted 2 months ago #

    Nothing to do with 3.9. I'm running 3.8.2 on a few sites and over the past few weeks this plugin has been hopeless.

  7. David
    WPMU DEV Support Staff
    Posted 2 months ago #

    Hi everyone,

    Thanks for reporting on all this. I've just been testing the smush operations on a live site and haven't had any trouble with this.

    I wonder if maybe Yahoo just had a bit of downtime with their service?

    Could you all please try again and let us know how it works?

    Also, if you could possibly turn the debug option on at Settings > Media, then report any errors back here, that'll help in troubleshooting it.

    If possible, could you also please try with no other plugins activated?

    And of course, if there are any other details you can think of that might be a culprit, please do let us know. Anything would help in this case as I'm not able to replicate the issue currently.

    Thanks,
    David

  8. ShawnLunny
    Member
    Posted 2 months ago #

    @David

    We run multisite. One side affect of the plugin failing is the media library gets a 1px X 1px image and the media library shows grey image place holders. In addition the media uploader on the post level and the general media library freeze up. You need to close the window and come back.

  9. JDN808
    Member
    Posted 2 months ago #

    I'm also having this issue.

    When I upload a picture to 'add media' in new post, it takes quite a white to load or gives an HTTP error.

    As soon as I disable the plugin, the images upload immediately.

    Thanks

  10. Splitterside
    Member
    Posted 2 months ago #

    Looks like the Yahoo APIs are down. Even accessing the Smush.it website stalls till timeout.

  11. greencode
    Member
    Posted 2 months ago #

    @David: I've enabled debugging and attempted smush a previously failed image and it's failed once again but where do I find the report?

  12. AmazingHulk
    Member
    Posted 2 months ago #

    Same problem with HTTP when uploading images. I deactivated WP Smush it and all works.

    Also plugin can be activated but you need to set "do not process images on upload." But it still wont work if you try to process afterwords.

  13. nmvdvjr
    Member
    Posted 2 months ago #

    Same here HTTP error, tried everything, deactivating plugin is only thing that works

  14. David
    WPMU DEV Support Staff
    Posted 2 months ago #

    Hi everyone,

    As @Splitterside kindly noted, unfortunately Yahoo's smush.it service appears to be intermittent right now as you may be able to see here:

    http://www.smushit.com/

    To avoid issues with uploads not completing currently, what you can do is turn off the auto-process feature like so:

    1. Go to Settings > Media.
    2. For the "Use Smush.it on upload?" setting, select "Do not process on upload".

    Here's a screenshot showing that option as well:
    https://docs.google.com/file/d/0B7bdY1zZi8JeUTFwQU04QzJNRzg/edit

    @greencode thanks for checking on that, the debug details should appear on screen but I think the issue is just that Yahoo's service itself is currently intermittent. It may be that they're getting hit with a lot of traffic.

    I'll run the matter by the team here to see if anything can be done. Again, thanks for reporting this everyone. We'll see what can be done from here. :)

    Cheers,
    David

  15. Jon Brown
    Member
    Posted 2 months ago #

    Same issues. I disabled WP Smush.it.

    Note: I ran regenerate thumbnails on the 1x1 featured images and that fixed them. https://wordpress.org/plugins/ajax-thumbnail-rebuild/

  16. worldviewpr
    Member
    Posted 2 months ago #

    DITTO. long waits either produce a timeout, or 404 and http: error message. saw that it involved smush.it. deactivated plugin and images load fine now.

  17. Satyapriya
    Member
    Posted 2 months ago #

    Same issue here. It's been happening for about 2 or 3 weeks now. At first it was just taking 20 seconds per image, now it is taking 20-40 seconds per image and resulting in a 404 timeout or HTTP error about 50% of the time. Please let me know if there is anything that can be done as this is one of the only image optimizers that work with my server software.

    Thank you.

  18. akivafeinstein
    Member
    Posted 2 months ago #

    I had the same issues starting a week ago. Thought it had to do with upgrade to WP 3.9 but no.

  19. David
    WPMU DEV Support Staff
    Posted 2 months ago #

    Hi everyone,

    Thanks for your further reports, unfortunately the service on Yahoo's end has been intermittent. The workarounds I mentioned above can help avoid issues.

    I'll mention them here for easier reference.

    You can turn off auto-processing like so:

    1. Go to Settings > Media.
    2. For the "Use Smush.it on upload?" setting, select "Do not process on upload".

    And you can set a lower timeout duration like so:

    1. Go to Settings > Media.
    2. For the "How many seconds should we wait for a response from Smush.it?" setting, specify a lower duration, perhaps 20 seconds.

    For reference also, you'll find details on some of this here:
    http://wordpress.org/plugins/wp-smushit/

    Hope that helps! Please feel free to ask if you have questions, we're happy to assist! :)

    Cheers,
    David

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.