WordPress.org

Ready to get started?Download WordPress

Forums

(HTTP 500 Internal Server Error) (12 posts)

  1. cweaver1210
    Member
    Posted 1 year ago #

    When trying to install WP3.5 I keep getting this error (HTTP 500 Internal Server Error).

    Host Settings:
    Basic Settings
    When both PHP4 and PHP5 are enabled on the webspace, PHP4 is used by default for PHP applications. To use PHP5 as a default PHP engine, you should disable PHP4 on the webspace.

    Name http://www.d1003923.charter-business.net
    IP address 64.210.232.72 (Shared)
    Webspace location 123064/
    CGI support On
    SSI support On
    PHP4 support Off
    PHP5 support On Run as a CGI application Version 5.3.3
    Error Documents On
    Webalizer Web Statistics On
    WAP support On

    I can install WP3.1 and everything works fine with PHP4 support on and is version PHP4.4.9.

  2. Tara
    Member
    Posted 1 year ago #

    Error 500 ISE is very generic and can be caused by numerous underlying issues. Your first step should be locating error log for your hosting account or asking support to help with that.
    - check with your host if the domain name is configured properly to point to public_html folder
    - It may indicate .htaccess issue. Regenerate .htaccess, and be sure the encoding in your text editor is Unicode No BOM
    - It may also indicate a problem with the configuration on the server. Usually your hosting company tech support can help.
    - it could be problem with the plugins, try resetting the plugins folder by FTP or phpMyAdmin.
    - it could be a problem with the theme. Momentarily, try switching to the default twentyeleven theme via FTP by renaming your current theme to rule out any theme specific issue.
    - if these steps don't help, download WordPress again and replace your copies of everything EXCEPT the wp-config.php file and the /wp-content/ directory with fresh copies. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory.

  3. cweaver1210
    Member
    Posted 1 year ago #

    I've tried a fresh install with a new database. When I run the wp-admin/install.php I get a white screen. The config file has the correct database name, username and password. I have an ip address for the host name and get a white screen. I've tried the internal host name and I get this message.

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at . This could mean your host's database server is down.
    •Are you sure you have the correct username and password?
    •Are you sure that you have typed the correct hostname?
    •Are you sure that the database server is running?

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.
    This is the database setup.

    172.24.194.123
    Server version: 5.0.83-community
    Protocol version: 10
    Server: 172.24.194.123 via TCP/IP
    User: u1003923_xxxxxx@172.24.194.124
    MySQL charset: UTF-8 Unicode (utf8)

  4. cweaver1210
    Member
    Posted 1 year ago #

    I just changed the database to allow access from external host and now am getting this message.

    Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the db1003923_word10 database.
    •Are you sure it exists?
    •Does the user u1003923_xxxxxx have permission to use the db1003923_word10 database?
    •On some systems the name of your database is prefixed with your username, so it would be like username_db1003923_word10. Could that be the problem?

    If you don't know how to set up a database you should contact your host. If all else fails you may find help at the WordPress Support Forums

  5. Tara
    Member
    Posted 1 year ago #

    but not able to select the db1003923_word10 database.

    -It sounds like either you have not created a database or your wp-config file is not set up correctly.
    Look at the detailed install instructions here: http://codex.wordpress.org/Installing_WordPress, especially steps 2 and 3.

    -also do check that your DB is MySql and not SQL or MSQL

    - Also review these threads:
    http://wordpress.org/search/Can%E2%80%99t+select+database?forums=1

  6. cweaver1210
    Member
    Posted 1 year ago #

    Thanks for the reply. I am currently waiting on a reply from my web hosting company to make sure the permissions for the database are setup correctly. The config.php file is setup correctly. Hopefully everything will get worked out from their end.
    Thanks

  7. cweaver1210
    Member
    Posted 1 year ago #

    This is the reply I received back from our web hosting company.

    Your settings (username/password/hostname/etc.) all appear to be set up correctly. There are 2 other settings you may want to look into.

    · If there is a host port or access port setting you may want to check to ensure that this is set to port 3306.

    · Since you are accessing from an external host, you may want to go to your database in our system, go to the Access Hosts tab and the information for the access host. WordPress should be able to provide the IP address.

    What I don't understand is why will WordPress 3.1 install correctly with the same settings but when I try to install WordPress 3.5 it doesn't install.
    This is the WordPress Error I am receiving now.
    Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the db1003923_word10 database.
    •Are you sure it exists?
    •Does the user u1003923_xxxxxx have permission to use the db1003923_word10 database?
    •On some systems the name of your database is prefixed with your username, so it would be like username_db1003923_word10. Could that be the problem?

    If you don't know how to set up a database you should contact your host. If all else fails you may find help at the WordPress Support Forums.

    Thanks

  8. wrightequine
    Member
    Posted 1 year ago #

    Did you ever get this solved. I'm having the same problem. Charter Business Hosting also....

  9. cweaver1210
    Member
    Posted 1 year ago #

    I didn't and can't get any help from Charter. They are saying they do not support any 3rd party software and that there is not a problem on their end. I'm just going to do something else.

  10. wrightequine
    Member
    Posted 1 year ago #

    I am having the SAME PROBLEM! Charter guys didn't even know what I was talking about when I said mysql database....

    Did you ever figure out how to fix this?

  11. epohs
    Member
    Posted 1 year ago #

    I have the exact same problem.

    If I revert to WordPress 3.1.4, and change my server settings to use PHP4 instead of PHP5 it will work.

    Switching to PHP5 breaks everything.

  12. Tara
    Member
    Posted 1 year ago #

    @epoh,

    -As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents from being able to track issues by topic. Despite any similarity in symptoms, your issue is likely to be completely different because of possible differences in physical servers, hosts, plugins, theme, configurations, etc. Also, It's easier for volunteers to help you if you have your own topic :)

    -Have you contacted your hosting provider?

Topic Closed

This topic has been closed to new replies.

About this Topic