WordPress.org

Ready to get started?Download WordPress

Forums

html5 tinymce woes --what am I doing wrong? (4 posts)

  1. Anointed
    Member
    Posted 3 years ago #

    I've spent a considerable amount of time building my theme to be as correct as possible to follow the html5 guidelines. Following html5doctor and a number of other authors has given me a pretty decent understanding of the setup.

    The problem I am having is not with my theme but with wordpress. When I manually edit my articles to wrap images with <figure> and use figcaptions, for some reason tinymce is completely screwing up my code upon submit.

    Could someone provide a link to some documentation on what I need to change in tinymce to get rid of this horrible behavior?

    thanks.

    *Yeah I know a lot of browsers don't support html5 yet, but if the theme properly shims the template I have yet to see any problem in a browser. Basically as far as I can tell we're ready for html5 now.

  2. jkovis
    Member
    Posted 3 years ago #

    I don't know if TinyMCE allows html5 elements or if there is a way to extend it to allow them, I'd look at using the tiny_mce_before_init hook since you should be able to overwrite any WordPress default settings.

  3. Carsten Bach
    Member
    Posted 3 years ago #

    maybe theese links could be interesting for you

    a ready to go filter function to hook tiny_mce_before_init and a nice html5 rebuild of wpautop

  4. Anointed
    Member
    Posted 3 years ago #

    Thank you for the links!

Topic Closed

This topic has been closed to new replies.

About this Topic