WordPress.org

Ready to get started?Download WordPress

Forums

Social Media Widget
[resolved] HTML validation issue - 1 missing space (5 posts)

  1. roadRUNN3R
    Member
    Posted 1 year ago #

    Hi, I'm having trouble passing HTML validation after the latest update. The W3C validator doesn't like that there is no space between -moz-opacity and class:

    -moz-opacity: 0.7;"class="fade"

    I tracked it down to line 409 in social-widget.php. Just wanted to note this for the next update :)

    http://wordpress.org/extend/plugins/social-media-widget/

  2. kamster94
    Member
    Posted 1 year ago #

    Yeah, I've found it too, and it makes me sad, it's like thorn in my ... :D Really, I like to have 'clean' website, so fix it asap. Or maybe someone has a solution for this? I can't find this line in php file, it's somehow generated from css, but I don't know where it's imported.

  3. roadRUNN3R
    Member
    Posted 1 year ago #

    You can fix it by editing \wp-content\plugins\social-media-widget\social-widget.php

    On line 409 look for:

    'class="'

    and add a space in front of the word class so it looks like this:

    ' class="'

    This will get overwritten with the next update though, hopefully with this simple fix implemented :)

  4. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed now in 3.0.3. ;)

  5. roadRUNN3R
    Member
    Posted 1 year ago #

    N1! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic