WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
HTML page? (8 posts)

  1. rgodke
    Member
    Posted 1 year ago #

    I am getting this message in the Google Webmaster tool. “Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead.” I am using WordPress plugin Google XML Sitemaps. What do I need to do to get rid of the HTML issue? Thanks for your help!

    rgodke@yahoo.com

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. Amado.Miami
    Member
    Posted 1 year ago #

    do you actually get a page called "sitemap.xml"
    Would look something like this:
    http://www.cec.fiu.edu/sitemap.xml

  3. rgodke
    Member
    Posted 1 year ago #

    I only have the original sitemap page that does not look like your example. How do I get the correct sitemap.xml to appear? Thanks very much for your help. rgodke@yahoo.com

  4. rgodke
    Member
    Posted 1 year ago #

    Update,
    I only have the original sitemap page that has words not links it does not look like your example, no links . This is the code on the sitemap page:
    <p><!-- ddsitemapgen --></p>

    I found the similar page with the links like your example when I went into setting-sitemap. It is current. Do I need to do something with that information so Google Webmaster tool can see it? where should the sitemap.xml file be located? Thanks very much for your help. rgodke@yahoo.com

  5. bwhobby
    Member
    Posted 1 year ago #

    I have the same problem with Google claiming the sitemap.xml file is in HTML format. Whatever sitemap generator I try to use, Google always rejects it. The xml validater I used here did not find any problems with the sitemap generated with the plugin. I also can see the sitemap with links when clicking on the sitemap link at the top of the settings page.

  6. rgodke
    Member
    Posted 1 year ago #

    bwhobby,
    I found the solution to my problem that worked for me!!!! In the Google Webmaster Tool you need to choose on the left side of page Optimization then Sitemap. On the right side of the page choose ADD/TEST SITEMAP. In the box following your website link type in sitemap.xml. This is how the widget stores the file the Webmaster tool needs. Good luck!
    Rgodke@yahoo.com
    http://homegardeningforbeginners.org/

  7. bwhobby
    Member
    Posted 1 year ago #

    rgodke,
    Thanks for the feedback, but Google still returns an HTML error. I have already gone through the process you described with results from several different XML site map generators, and I always get the same error from Google. I have even edited out the offending code on line 4 that Google references in my current site map and still no success. My site map page looks exactly like the example given above when rendered online, so I would assume there are no errors in the XML code.

  8. NeusGC
    Member
    Posted 1 year ago #

    bwhobby did you solve the problem?

    I have the same problem as you. We are working on a multisite ecommerce wordpresse installation and I used the last beta version of Google XML Sitemaps for multisite. Webmaster tools says that the same error: “Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead.”

    But I'm pretty sure that my site has already a sitemap with xml format, as it's: http://www.mysite.com/sitemap.xml

    Anyone knows what's wrong? What mistake I am committing?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic