WordPress.org

Ready to get started?Download WordPress

Forums

HTML not appearing in posts on front page (13 posts)

  1. Icebox
    Member
    Posted 9 years ago #

    Hi,
    I've been testing posting on my site - http://www.echoplayer.com and I can't get HTML to display in my posts on the front page.
    On the above, the "Scrapland" and "hello" posts are showing the text in the Excerpt field (and so html shows fine).
    Yet the top post - "Title"has html formatting in it, yet it doesn't show it. If you click the actual title to go the post's page, it'll show the image and the italicised text - how come they don't show up on the main page?
    Thanks,

  2. Icebox
    Member
    Posted 9 years ago #

  3. Icebox
    Member
    Posted 9 years ago #

    Can anyone help at all?
    Please

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    In Options, is this checked ?
    For each article, show: full text

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    You are right ! ... I'll look at my 1.2 testblog

  6. Icebox
    Member
    Posted 9 years ago #

    Beel,
    The excerpt text shows fine - it's the text for a normal post that doesn't display the html formatting.
    Do you have any idea why it does that?

  7. Icebox
    Member
    Posted 9 years ago #

    Sorry to keep bumping this, but I really need to get this working, otherwise my blog is messed up.
    Does anyone know how to fix it?
    Thanks,

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Could you post here what you actually wrote for one post, and indicate which one it is on your page ?
    I'm not sure quite what you mean ?

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    What plugins have you got activated right now ?

  10. Icebox
    Member
    Posted 9 years ago #

    Just that Search Hilite, that comes with it.

  11. Daisyhead
    Member
    Posted 7 years ago #

    I am having this same issue with one of my blogs. The HTML formatting shows up on the individual entry page, but not in the entries on the index page.

    Any ideas??

  12. Chris_K
    Member
    Posted 7 years ago #

    wow - two years later...!

    Sounds like the theme you're using uses the_excerpt() instead of the_content() on the index page.

    - http://codex.wordpress.org/Template_Tags/the_excerpt
    - http://codex.wordpress.org/Template_Tags/the_content

    Option 1: Edit the theme and replace the_excerpt with the_content

    Option 2: If you like the shortened post view, but want some html to show up, look at using this plugin http://guff.szub.net/2005/02/26/the-excerpt-reloaded/

  13. spencerp
    Member
    Posted 7 years ago #

    If you're trying to show, example: the html code itself, like this: <html> and so forth.. on the index page, you could always try this plugin:
    http://priyadi.net/archives/2005/09/27/wordpress-plugin-code-autoescape/

    I currently have that running on my blog, used it once..but it was showing the code on the index page, in a post. Again, I'm not sure if this is what you want exactly though.. but, just wanted to throw it out. =)

    spencerp

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.