WordPress.org

Ready to get started?Download WordPress

Forums

Debug Bar Actions and Filters Addon
[resolved] HTML error: 'Saw U+0000 in stream.' (11 posts)

  1. jrf
    Member
    Posted 9 months ago #

    Hiya Subharanjan,

    Absolutely love the plugin! Probably one of the most useful ever when developing ;-) Thank you.

    I did however come across some very minor issues amongst which the message in the subject of this issue. I've fixed them locally and found your GitHub account, but can't find the repository for this plugin...

    Would love to send you a pull request with the fix.

    Oh... and I also found a 'fork' (not really as your repo isn't there yet) by AramZS which covers a fix for closures. Would be great if that could be pulled in too (did so locally already, but would be good to have it in the plugin core).

    Smile,
    Juliette

    http://wordpress.org/plugins/debug-bar-actions-and-filters-addon/

  2. Subharanjan
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Juliette,

    Thanks for letting me know. No, I do not have a Github repo for this plugin. but I will surely have a look at this fix for the closures and will add it to the plugin in the next version.

    Also, I will create a Github repo for this and let you know.

    Thank you very much again !!
    Subh

  3. jrf
    Member
    Posted 9 months ago #

    Excellent! As soon as you let me know the repo is online, I'll send you the pull request with my fixes.

  4. Subharanjan
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Juliette,

    Just merged the changes you have done to the plugin. Thank you very much for the help. Changes in trac

    Please check if this works now.

  5. jrf
    Member
    Posted 9 months ago #

    Hi Subharanjan,

    I can see that the new version has been released on the WP repo page, but strangely enough it's not being offered to me as an upgrade to existing installs yet. Can't see anything wrong in trac though, but this might need some looking into.

    Smile,
    Juliette

  6. Subharanjan
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Juliette,

    Yes, when somebody is on "trunk" version (initial release) of the plugin, it is not showing the Upgrade Notification. I tried downloading the tagged version i.e. Version 0.2 of the plugin and its now showing me the notification for Version 0.3. http://awesomescreenshot.com/06b21najd5

    Not sure why it doesn't work for the initial setup of this plugin.

    Thanks,
    Subh

  7. jrf
    Member
    Posted 9 months ago #

    I seem to remember the same issue with another plugin and - don't ask me why -, apparently it helped to add the following at the top of the php files to force the plugin to also show the updates to the old/original versions. May be worth testing ?

    /**
     * @package debug-bar-actions-and-filters-addon
     * @version 0.3
     */
  8. Subharanjan
    Member
    Plugin Author

    Posted 9 months ago #

    Did add these lines but still doesn't work. Does this work for you ?

  9. jrf
    Member
    Posted 9 months ago #

    Unfortunately no, still doesn't...

  10. Subharanjan
    Member
    Plugin Author

    Posted 9 months ago #

    Going to my version numbers soon for the sake of showing upgrade notification. Got a nice lesson from this discussion. http://wordpress.org/support/topic/no-notification-being-displayed-for-plugin-upgrade-1?replies=2

    From 0.11  -> 1.1
         0.2  --> 1.2
         0.3  --> 1.3

    This way it will be streamlined. :) Thanks for pointing out this issue !!

  11. jrf
    Member
    Posted 9 months ago #

    Hurray! It's working now ;-)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.