WordPress.org

Ready to get started?Download WordPress

Forums

HTML error Media Upload -GoDaddy Hosting- [FIX] (6 posts)

  1. newbasick
    Member
    Posted 2 years ago #

    First of all, I would like to say that this HTML error from using the flash uploader when uploading media files such as images can have multiple solutions. I am posting this solution because after sifting through countless forums I had only seen it mentioned once and I believe it deserves its own thread. I am not an expert at web design.

    Okay, so here is the issue that had to be resolved:

    Every time I tried to upload an image above 130kb the flash uploader would stop at 100% crunching and show a red "HTML error" message. Switching to the browser uploader produced an error that looked like this:

    http://img.photobucket.com/albums/v61/newbasick/newbasickissue.jpg

    Now, after trying numerous ways to fix this issue, including editing the .htaccess file, changing permissions on the upload folder, setting the upload folder in settings within the wordpress dashboard, editing my php.ini file, disabling all plugins, changing picture dimensions, and a few more that I cannot remember, I found myself right where I started... nowhere.

    However, while searching for a solution I happened upon this post here:

    http://wordpress.org/support/topic/http-error-on-upload-31rc3?replies=15

    Now towards the bottom a user reports their pictures were being accepted when their file size was less than 130kb. I tried creating one and to my amazement it went through. Thus, I submitted a ticket to GoDaddy asking for them to relay me the value that maxrequestlen was set to.

    Long story short, GoDaddy support is completely useless. Not only did they never get back to me on the value, they started claiming the problem was my code/scripting (if you ever use their support service this is not uncommon). Anyway, I decided to take it upon myself to find a solution.

    After searching quite a bit more I happened upon this gem:

    http://halytech.net/2009/12/09/fastcgi-500-errors-w-godaddy/

    In this post, the users report that disabling Fast CGI solved a similar issue. The only remaining thing to figure out was how to do that considering GoDaddy's terrible admin interface. Well, an hour or two later, I figured it out.

    This is what you need to do:

    1) Log in to your GoDaddy account
    2) Go to My Account
    3) On the left sidebar click Hosting
    4) In the My Products section click on the green Launch button to launch the control center for the site in question
    5) A new window will pop up. Click on Settings to expand the section
    6) Go to File Extensions Management
    7) A table pops up with a bunch of extensions. Check to see if the .php4, .php, and .php5 extensions have "FastCGI" in the Runs under section.
    8) If they do, click on the paper & pencil icon, aka the edit button, and change it to the same extension without FastCGI in it. The settings take a minute to go through.
    9) Log out, you are done. Try testing an image for upload.

    This workaround only works if you have GoDaddy hosting, and may not solve the problem for all cases. However, if you are like me, anything is worth a shot. Also, I am not an expert at web development, so I do not know what turning off this Fast CGI will do to your site. For some it may cause issues. For my site, I have yet to see any problems.

    I just want to give a shout out to all those on these forums that have been providing priceless support to those of us running WordPress. Thank you for your time, and I love you all.

    Also, if you are using GoDaddy, you should probably switch hosting. :P

  2. RichardWPG
    Member
    Posted 2 years ago #

    You're welcome

  3. audace
    Member
    Posted 2 years ago #

    Thanks so much ! you are a lifesaver

  4. Go Daddy
    Go Daddy Support
    Posted 2 years ago #

    Hi, WordPress users... I wanted to followup on this issue.

    Around the time newbasick was having this issue, we heard the same thing from other users and provided the very same advice to resolve the issue in the short-term. It all came about after an update that we made included an unexpected change. We quickly found the cause (several days ago) and made a system-wide change to avoid the issue. So, to be clear, you should not have this issue any longer, even if FastCGI is enabled. Kudos to newbasick for his work to help others during the time when this may have been affecting them.

    As always, if any of our users are having trouble, we want to hear about it. Please feel free to contact our Support staff if you think there's a problem we should know about. Contact info is here: http://x.co/ZyKc

  5. SteveNetRivet
    Member
    Posted 2 years ago #

    Go Daddy, I'm afraid our customers are still experiencing this issue.

    One customer even reports that the option to select a non-FastCGI PHP engine has been removed from her admin, so this workaround is not possible.
    Worse, GoDaddy support continues to insist to her that they "are unable to support third party application or plug in issues" and do not appear to be listening to the customer's request to help with the FastCGI issue. We've given our customer language to request moving her account onto another server with the non-FastCGI option, and this has fallen on deaf ears.

    Whatever is going on with GoDaddy servers still needs to be addressed. I'd love to hear an update.

  6. Go Daddy
    Go Daddy Support
    Posted 2 years ago #

    SteveNetRivet,

    I'd like to investigate the specific account you're referring to, but I need to know the domain name. Have your clients' interactions with our Support staff been on the phone or through email? If they were through email, could you post the Incident ID number here so I can find it and review the situation? If there's no existing incident, you can create one here - http://x.co/heretohelp - or just post the domain name in this thread.

    For the record, the issue users were experiencing when this thread began has been resolved. I can only guess that what your client is seeing is caused by something different even if it results in the same symptom. Furthermore, if FastCGI is an option on an account, there should always be an option to disable it. Yet another reason I'd like to look into this myself - if there's something unusual or unintended going on with the account, I want to catch it as quickly as possible.

    I hope to see your response soon.

Topic Closed

This topic has been closed to new replies.

About this Topic