WordPress.org

Ready to get started?Download WordPress

Forums

Raw HTML
HTML entities in [raw][/raw] tag if visual editor disabled (14 posts)

  1. bahead
    Member
    Posted 1 year ago #

    I was having issues with the visual editor removing line breaks, so I followed the developer's advice on preventing this by disabling the visual editor in my profile.

    However, after I do this any HTML in the [raw][/raw] tag in the HTML editor gets converted to HTML entities after save.

    For example:

    [raw]<br />[/raw]

    gets converted to:

    [raw]& lt; br /& gt;[/raw]

    [note: I added spaces to the HTML entities in this code to get them to display in the post]

    Is this the expected behavior when the visual editor is disabled? Renabling the visual editor stops this behavior.

    Also, note that checking any or all of the boxes in the Raw HTML plugin had no impact on this problem.

    http://wordpress.org/extend/plugins/raw-html/

  2. mbrsolution
    Member
    Posted 1 year ago #

    Hello have you tested the latest version?

    Kind regards

  3. bahead
    Member
    Posted 1 year ago #

    I just upgraded to version 1.4.9, tested this again, and the problem still exists. After I disable the visual editor, edit a post/page with HTML code in [raw][/raw], and save, the code gets converted into HTML entities (which are then rendered as code on the page rather than interpreted as HTML). This also happens with any existing HTML in [raw][/raw] tags in the page/post.

  4. mbrsolution
    Member
    Posted 1 year ago #

    Hello, I have noticed that you are still using WordPress 3.3.2. Have you thought of updating to the latest version WordPress 3.5.1?

    It is always important to keep your WordPress updated, plugins and themes to prevent your website or blog from being hacked.

    As always if you do decide to update, which is my recommendation make sure that you have a current backup just in case anything goes wrong.

    Kind regards

  5. mbrsolution
    Member
    Posted 1 year ago #

    Hello have you tried the latest version?

  6. Jan-Philip Gehrcke
    Member
    Posted 1 year ago #

    As of today, I am using the latest versions of both, WordPress and the Raw HTML plugin. I observe the same. In my work flow, I prefer working in the text-only editor, so this is quite annoying.

  7. mbrsolution
    Member
    Posted 1 year ago #

    Hi Jan-Philip Gehrcke have you got the following settings checked?

    Disable wptexturize
    Disable automatic paragraphs
    Disable convert_chars

    Kind regards

  8. Jan-Philip Gehrcke
    Member
    Posted 1 year ago #

    mbrsolution, with all Raw HTML checkboxes enabled at once the behavior is the same.

  9. mbrsolution
    Member
    Posted 1 year ago #

    Hi I also have installed TinyMCE Advanced installed.

    I have also tested both plugins on WordPress 3.6 beta 3 and it works. Perhaps you can give it a try by installing the above mentioned plugin.

    Kind regards

  10. LK137
    Member
    Posted 1 year ago #

    I am having the same problem. One specific character entity is still being displayed (greater than) despite surrounding the code in the [raw] [/raw] tags. Need help ASAP.

  11. mbrsolution
    Member
    Posted 1 year ago #

    Hi LK137, have you tried simply adding < code > </ code >.

    Kind regards

  12. tdmac
    Member
    Posted 1 year ago #

    I'm experiencing this trouble, too. Exactly same scenarios as Jan-Philip Gehrcke. I keep the visual editor disabled because it adds junk in to my code and reconfigures all my code.

    MY SETUP:
    I'm using current wordpress version 3.6
    Raw HTML plugin Version 1.4.10
    TinyMCE Advanced installed

    Have these Raw HTML settings checked:
    Disable wptexturize
    Disable automatic paragraphs
    Disable convert_chars

    What's happening:
    HTML editor gets converted to HTML entities upon save.
    Also, I get this displaying in my page, !RAWBLOCK0!

    I'll keep looking for solutions, but if anyone has advice, I'd appreciate it!
    Thanks!

  13. onecutekins
    Member
    Posted 1 year ago #

    I'm not 100% sure this is the SAME issue as everyone else here, but with [raw][/raw] and all options checked my tag doesnt work :( I looove that this stops WP from ruining my code.. but why is it removing my breaks? V_V

  14. tay23
    Member
    Posted 11 months ago #

    I've been having exactly the same problem myself - when using [raw]...[/raw] as the tags.

    However, I've just tried using <!--raw-->...<!--/raw--> instead, and it's fixed the problem!

    Try giving that a go & see if it works for you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.