WordPress.org

Ready to get started?Download WordPress

Forums

HTML Editor Jump-to-Start Problem Fix (6 posts)

  1. engineer82
    Member
    Posted 3 years ago #

    Can anyone having this problem try out this workaround?

    From the Dashboard:

    1. Click Posts then from the Edit Posts table, find a Post that you know is big enough to need to be scrolled in the editor window. Hover you mouse over the title of the post and click the Edit prompt that appears.

    2. Once in the editor, click HTML .

    3. Click Dashboard and if asked, confirm that you want to abandon editing.

    4. Repeat step 1.

    I find that the post is now editable without any jumping.

    Let us know if it works for you - E&OE!

    John

  2. happyches
    Member
    Posted 3 years ago #

    Damn, it seems to work for me as well, buy why I wonder?
    And how can we avoid having to edit a post twice just to avoid that irritating scrolling html? :)

  3. engineer82
    Member
    Posted 3 years ago #

    Happyches,

    "But why?". I can't answer that. I've only been involved with WordPress since Saturday when I was asked to move a WordPress blog from one host to the other. At the end of the process, I asked the user - a relative of mine - to exercise the blog and see if everything worked as expected. The report back was "fine - but there are things that still don't work" amongst which was HTML editing. A few minutes on the web revealed that there were many people having the same problem - and even more people offering quite bizarre remedies. 10-15 minutes playing with the HTML editor got me to the ideas I published yesterday - and after somewhat more time, I'd drafted and posted a recruitment notice for third-party testers - of which you are the first!

    As regards how complex this workaround needs to be, what I published yesterday was supposed to be a very simple test sequence which would prove or not whether I was on the right track. As I do seem to be on the right track, you might like to try to simplify the process. I suspect that a good algorithm might be something like:

    "Whenever you have finished editing something, make sure the last thing you do is to switch the editing mode to HTML. Then the next edit will work in HTML mode"

    As I've a lot on my plate at the moment and I won't be able to access the re-hosted blog, would you like to try this supposition and report back? If it works it will certainly simplify the workaround.

    Regards

    John

  4. Dave in MT
    Member
    Posted 3 years ago #

    Hi guys,

    We've hit the same problem--cursor jumps to the top in HTML mode. I see these posts are a couple of months old...I don't suppose there's any fix in the works? We've downloaded the latest version and there seems to be no change at all.

    Thanks
    Dave in MT

  5. e7
    Member
    Posted 3 years ago #

    I can confirm that this problem still persists. IE8 can easily be switched to compatibility mode to stop it from jumping around, just click the button next to the address bar and the jumping stopped for me.

    Hopefully WordPress can fix this issue in future revs, or when IE9 comes out things will be better.

  6. 0xy9en
    Member
    Posted 3 years ago #

    Hi all,

    Had almost the same problem but in my case the cursor in the html editor pane jumped to the end of the text everytime a draft was saved. In my case this was as soon as the cursor was plced elsewhere in the window.

    I tried various editors to solve this problem. No cure.

    I tried the above option. Bingo.

    To add to the sequence. It does not matter how you enter the post/page, as long as you use the Dasboard button to exit the post/page. Upon re-entering the post/page the cursor keeps it position.
    Going into the WYSIWYG viewer you need to redo the sequence.

    Lots of fun publishing.

    Greetings Oxygen.

Topic Closed

This topic has been closed to new replies.

About this Topic