WordPress.org

Ready to get started?Download WordPress

Forums

HTML editor doesn't work (28 posts)

  1. BizCoach
    Member
    Posted 8 years ago #

    When I'm writing a post there's a button that says HTML. When I click in another window pops up which should contain HTML code (I assume) but it's empty - this no matter how much or how little content is already in my post.

    I'm using FireFox 1.5.0.1 browser on a Win XP machine.

  2. vinnym
    Member
    Posted 8 years ago #

    I have the same problem, and it looks like they are ignoring it.

  3. vinnym
    Member
    Posted 8 years ago #

    From what I've discovered, this seems to be a Firefox problem. It works fine in IE, Opera, etc. This is on a windows machine.

  4. moshu
    Member
    Posted 8 years ago #

    Yes, vinnym, based on reports and complians here it seems FF 1.5 was a premature release: a lot of things don't work properly in it. So, you guys would do better posting these in their forum :)

  5. vkaryl
    Member
    Posted 8 years ago #

    I'm using FF1.5.0.1 on WinXPPro, and the html window works as designed (when I activate the wysiwyg, of course). I see content in both write post and manage post screens. Maybe something with one of your options settings in FF? Or perhaps it's XPHome you're using, not Pro? My laptop is a bit different on Home than my desktop on Pro (which is why I'm going to put Pro on it shortly....)

    I'm booting the laptop to check with it as well, I'll post back in a bit....

  6. vkaryl
    Member
    Posted 8 years ago #

    Back.... yes, works fine on my laptop XPHome install as well.

  7. stevation
    Member
    Posted 8 years ago #

    I'm having the same problem as the original poster. Vkaryl, you appear to be the first person I've seen post on this who is actually getting it to work right with FF.

    I'm on an XP Home machine right now. I'll have to try it on my laptop at work tomorrow with XP Pro and see if I get any difference.

    The only thing I did to FF after installing it tonight was to install the Google Toolbar, which wasn't easy and crashed FF, so maybe my FF is screwed up from that?

  8. stevation
    Member
    Posted 8 years ago #

    OK, now I'm on my laptop running Win XP Pro, with the same version of Firefox and the same WP blog, and the HTML editor works fine.

    I would think the problem is caused by XP Home, but Vkaryl says it worked fine on XP Home. Two things are different on this FF installation: 1) I never installed Google Toolbar on this one, and 2) the home version had an extension for sending error reports to Mozilla (I think that's what it was). The one that's working fine has no extentions installed. When I get home, I'll try removing that extension.

    Steve

  9. Chris_K
    Member
    Posted 8 years ago #

    I have FF 1.5x running on 3 (2 xp pro, one FC5 linux) machines and all work as expected with the "HTML" button.

    Perhaps the next interesting step would be to have those that don't have it working post what FF extensions they have enabled and see if anything pops up from that?

  10. jacked
    Member
    Posted 8 years ago #

    i'm running FF 1.5.x and have AdBlock, FasterFox, SearchStatus and the Google Toolbar installed and am having issues with the HTML button disappearing on me. I tried checking in IE and the HTML button nor the graphic buttons for the other commands work... the graphic buttons have been changed to grey boxes

  11. stevation
    Member
    Posted 8 years ago #

    So I went home and uninstalled Firefox and then reinstalled it with no extensions. It still behaves the same, but it's clear from the settings in the new installation that the old installation's settings were saved and used in the new installation (except for the extensions that I didn't install). I may have to do a cleaner uninstall and then reinstall. I'd have to figure out registry keys to delete and such. What a pain.

    I'm sure someone out there knows the answer to this but they just haven't seen this thread yet. There must be some setting or conflict with other software or something that could be fixed that would make FF able to use the HTML button in the WP editor!

  12. stevation
    Member
    Posted 8 years ago #

    Last night, I uninstalled FF again on that machine with Win XP Home, removed all registry entries that said anything about Firefox and some that referenced Mozilla. Reinstalled it with no extensions, and it's still acting the same. Still working fine on my laptop with XP Pro, though. And I even installed the Google Toolbar on the laptop, and that didn't mess it up. Any other ideas out there? If it's not XP Home that's messing it up, what else could it be?

  13. dutch_gecko
    Member
    Posted 8 years ago #

    Off the top of my head, there are three obvious things that could be doing it:

    • Adblock extension
    • NoScript extension
    • Your JavaScript settings
    • The first two you can check for in Tools|Extensions (not alphabetical), and the second you can change in Tools|Options|Content. There is an "Enable Javascript" checkbox as well as and "Advanced" button. Make sure to check that all the Advanced options are Enabled.

      If that works, you can re-disable those little JS niggles one by one and keep checking to make sure the HTML box hasn't broken.

      I had something even odder, where the box kept shrinking, but I gave up on it and abandoned the WYSIWYG editor :)

    edit: just so you know, Firefox practically doesn't use the registry at all (only for assosciations and the start menu). It stores all your settings in a profile, which is located at:
    [system drive]:\Documents and Settings\[your username]Application Data\Mozilla\Firefox\Profiles\Default.[garbage]\

    Try changing your JS settings first, and if that fails, delete the whole of the Profiles folder and reinstall Firefox.
    P.S. This will destroy your bookmarks! If you want you can copy out the bookmarks.html file in your profile, and copy it back when done.

  14. kylekorleski
    Member
    Posted 8 years ago #

    I've had this problem with Firefox but I wanted to make sure it was just firefox and not WP. It turns out that the WYSIWYG doesn't work on Opera and there is NO way that I am using IE.

  15. stevation
    Member
    Posted 8 years ago #

    Thanks for the tips, gecko. I don't have any extensions installed, but I did go and enable all the advanced options for javascript. Still no improvement. Also, when I uninstalled yesterday, I did remove the profile folder.

    I also made sure I had the same version of Java runtime environment on this PC as on my laptop (where it works fine), and that didn't help either. Is there something else that sets the environment for a web page like this that could be different on the two PCs?

    - Steve

  16. Splutter
    Member
    Posted 8 years ago #

    Have any of you Windows guys tried the Bon Echo release - works fine on my Mac

  17. Splutter
    Member
    Posted 8 years ago #

    Now works on Firefox 1.5.0.2 as well as Opera 9pre2 (Mac anyway)

  18. vinnym
    Member
    Posted 8 years ago #

    Doesn't work on Firefox 1.5.0.2 Windows, however, nor Opera's newest 8.x build. I don't think this should be treated as a browser bug. It's a WordPress issue. This feature should have been tested on all available browsers at the time of release AND all platforms. I know there are a ton of Macophiles here, but let's not forget that ninety-some percent of the world is still using Windows. More thorough testing could have prevented it. One of the attractive features (for me) was the WYSIWIG editor, but it, in fact, only works on Macs and in Internet Explorer (and I'm not switching back to IE just to use WordPress). So, had I know this beforehand, i would have gone with another blogging system. Developers should make sure their stuff actually works before advertising it.

    I guess there is no solution other than wating for another release of Firefox, or Opera 9 to finally come out of Beta. Or buy an over-priced Mac.

  19. Chris_K
    Member
    Posted 8 years ago #

    One of the attractive features (for me) was the WYSIWIG editor, but it, in fact, only works on Macs and in Internet Explorer (and I'm not switching back to IE just to use WordPress). So, had I know this beforehand, i would have gone with another blogging system. Developers should make sure their stuff actually works before advertising it.

    I'd have to beg to disagree. I use it, daily from many windows machines all running Firefox 1.5.0.2, IE7 beta 2, IE6 and Opera 9 beta. Oh, and linux (FC5) FF 1.5. The only one that doesn't handle the WYSIWYG editor "properly" is Opera 9. It is close... but very very slow. (and quite frankly, many Mac folks are upset since it doesn't work with Safari... so not sure about your macophile crack.)

    In other words, while folks who have problems DO post here, you can't take that as an indication that the world has ended for editing. Obviously all the folks who do NOT have problems aren't remember to swing by and drop a note indicating that all is still working well. Nor, of course, would I expect them to do that.

    Did you see the post on this topic earlier today mentioning that the person missed a .js file as part of the install?

    Firefox works great for me with the extensions I run. But there are so many dang extentions out there for it that can change behavior that damning the developers for not hitting one person's combination of extensions is hardly fair. Or even 6 people's combinations.

    Just my 2 bits.

  20. vinnym
    Member
    Posted 8 years ago #

    "The only one that doesn't handle the WYSIWYG editor "properly" is Opera 9. "

    A quick glance at this thread tells me that isn't true.

    But, let me ask you this: does your windows machine(s) have sp2 installed? maybe that's the problem. (never thought of that.) Could there be something in sp2 (a security update or something) that is preventing the html editor (within the WYSIWIG editor) to work correctly? I've tried on Mozilla, Firefox default settings (no extentions), Sea Monkey, Opera-- a fresh installs-- none of which worked. And I really doubt anyone intended this thing to ONLY work in IE.

    I guess I shouldn't have jumped the gun here, but with all the comlpaints about this not working it just doesn't appear to be a simple browser issue.

  21. stevation
    Member
    Posted 8 years ago #

    I am convinced it's a Windows XP Home issue. I've installed Firefox on two PCs with XP Pro, and both work just fine with the WP editor. But my home PC, which runs XP Home, is having the problem still, even with the new update to Firefox. It's not the fault of some obscure extensions, either, because I installed it with no extensions and still had the problem. The only extension installed right now is Google toolbar.

    Vinnym, are you using XP Home or Pro? How about you, HandySolo?

  22. Chris_K
    Member
    Posted 8 years ago #

    Good thoughts, but alas -- I do have SP2 on all the XP machines. But yeah, there's got to be *something* about the Firefox installs or the blog installs that is causing some folks to have these issues. Earlier in the thread I had suggested the FF users include what extensions they're using (if any) to see if there was something common there.

    Based on your post, I'd have to suspect the installation, not the browser. Unless you dutifully block javascript from all your browsers? That would definitely kill it.

    Other than that, I'm just as stumped as most others.

    But for ME, Opera 9 beta is the only browser I've used that doesn't handle WYSIWYG perfectly.

    Say, here's a thought: suppose you went to wordpress.com and created a free account (if you don't already have one for Akismet's key). With that installation, how does the wysiwyg editor work?

  23. vinnym
    Member
    Posted 8 years ago #

    To answer Stevation, I'm using xp pro. But that's not it...

    Okay, signed up at wordpress.com and the html popup editor works in Firefox. But, it's comlpetely different than the one on my site and I'm using the newest release (2.0.2). Is the wordpress installation older? And is there a way to interchange (downgrade?) the scripts for the editor?

    I notice that the wordpress.com installation doesn't have a post preview. Has anyone tried the html editor after disabling the preview?

  24. vinnym
    Member
    Posted 8 years ago #

    Also found this, which may be a solution for some:
    http://performancing.com/firefox

    has anyone tried this?

  25. obentz
    Member
    Posted 8 years ago #

    I had also two threads started with the same/similar topic, obviously my topic description wasn't appealing enough . hardly anybody answered. :-)
    Anyway... Now I see that there must be something seriously wrong: On my home laptop (XP Home / latest Firefox and IE) I do not get to see the wysiwyg-editor, both browsers report a bunch of Javascript errors.
    On my office machine I use XP professional and the latest browsers - no problem, I can switch between html and wysiwyg editors. Both work perfectly. I have the same Java runtime environments istalled and have tried uninstalling all extensions and so forth, did a reinstall of Firefos... the works.
    So, maybe people in this thread are right, it has to something to do with Windows XP Home vs. Professional. Very weird.
    All I can say: Somebody should fix this.
    A tip: I have startet to use two blogging programs to override the wp-webinterface: Blogdesk and Qumana. Both very neat.
    Cheers, everyone!
    - obentz

  26. obentz
    Member
    Posted 8 years ago #

    vinnym,
    I stumbled across performancing.com/firefox today during my search for a solution. I didn't try it though because after some research I found that it doesn't sport all the features that the two progams I mentioned before have. And I don't see any advantage in a Firefox extension as compared to a little standalone editor with html and wysiwyg features.

  27. Splutter
    Member
    Posted 8 years ago #

    Yup, as a Mac folk I'm dis-chuffed that webkit browsers won't do the visual rich editing thing (and I don't see even the imminent release of Omniweb 5.5 curing this) but I always carry a copy of Camino around - that works just fine.

  28. Splutter
    Member
    Posted 8 years ago #

    Wahay - Omniweb 5.5 Sneaky Peak works with the Visual Rich Editor when spoofed as Firefox 1.5.0.1 (haven't tried other settings)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags