WordPress.org

Ready to get started?Download WordPress

Forums

HTML editor broken? (8 posts)

  1. Andrei
    Member
    Posted 4 years ago #

    Hello everyone,

    Lately (since I upgraded to the 2.9.x family) I've been having severe problems with the HTML editor and I wanted to know everyone else's experience with this as I'm considering to make a detailed bug report.

    In the 2.9.1:
    - when editing HTML in the editor, some tags (div's mostly) would dissappear when witching back to Visual. Other effects include removing of html entities (such as  ). Empty tags (except the <p>'s that wordpress adds) are usually removed also.

    In the 2.9.2:
    - now when editing in HTML, I -have to- move back to Visual. If I click on Publish/Update directly from HTML view, I can see any change I made to the post disappear right before I'm notified the post was updated.
    - when saving, tags I manually added are progressively trimmed and eventually eliminated (eg, I add something like <div style="clear:both">   </div>, later it becomes div style="clear:both"> </div>, then div style="clear:both"> </div> and is ultimately removed)

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    No problems with the HTML editor across multiple sites here. Not in 2.9.1 or 2.9.2. Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

  3. Andrei
    Member
    Posted 4 years ago #

    I've tried those things and still no result

    I get the same issues in a fresh plugin-less wordpress installation, but only in one direction (eg, I can switch from one view to the other fine, but if I edit something in HTML view, clicking update cancels any change I made).

    Also, I cannot use the

     tag at all, after saving all the spacing inside the tag dissappears and everything appears on a single line.
  4. ianbt7
    Member
    Posted 3 years ago #

    Same things happens with me. I use gadgets from google, like things in <iframe>s, etc...

    I start in html view, paste the html code, switch to visual, then back to html view, and -- poof-- the whole html code mess is gone!

  5. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    that is how WP works currently unfortunately. You cannot switch between editors. If you use html, you have to stick with it for that post

  6. ianbt7
    Member
    Posted 3 years ago #

    Thanks for the reply,

    I just disabled "visual editor" for now.

    Thanka again

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    for sure! itd be great if that gets fixed some day...but for now, it is what it is eh!

  8. relaxedguy
    Member
    Posted 3 years ago #

    I have the same problem with <div class="clear"></div> I write post in rich text then switch to html editor, add the div, switch back to rich text and it gets removed.
    +1 for a fix.

Topic Closed

This topic has been closed to new replies.

About this Topic