WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] htacess in admin not htaccess (10 posts)

  1. projectone
    Member
    Posted 6 years ago #

    Trying to fix my permalinks. Created 1.htaccess and uploaded to the root directory that I am using. Renamed .htaccess and changed numeric value in file attributes to 666. If I try and use date and name based I get "No input file specified." If I go with just postname I get a 404. Started poking around and found .htacess in wp-admin. Figured the misspelling might have something to do with it. Renamed .htaccess and changed numeric value in file attributes to 666. Still nothing. Any ideas?

  2. projectone
    Member
    Posted 6 years ago #

    Opening .htaccess in the template editor of WP reveals a blank file

  3. projectone
    Member
    Posted 6 years ago #

    Anything?

  4. projectone
    Member
    Posted 6 years ago #

    wp-admin/.htaccess contains
    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>
    And nothing else

  5. Kafkaesqui

    Posted 6 years ago #

    Misspelled or not the .htaccess should not reside in wp-admin/ but rather the root directory of your site, or the directory your WordPress blog was installed to, depending on how things are set up.

    Note that if for whatever reason WordPress cannot write to your .htaccess, you can always copy and paste into it the rewrite rules which should appear at the bottom of the Permalink Options page.

  6. projectone
    Member
    Posted 6 years ago #

    ie. /index.php/%year%/%monthnum%/%day%/%postname%/ ?

    Should I write
    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>
    to the root .htaccess and delete the wp-admin/.htaccess

    Currently the root .htaccess is blank

  7. Kafkaesqui

    Posted 6 years ago #

    At the *bottom* of Permalink Options. If WordPress deems it cannot write to the .htaccess file, it would display a text box with something like the following in it:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
  8. projectone
    Member
    Posted 6 years ago #

    There is no text box at the bottom of the permalink options, but regardless of the changes I make to the permalink structure, .htaccess remains blank. Checked w/ host and mod_rewrite is installed and activated

  9. projectone
    Member
    Posted 6 years ago #

    pasted
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    into blank .htaccess and now we're good to go

  10. e13o13
    Member
    Posted 6 years ago #

    I was having the same issue and came to the same resolution with pasting:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    but now, my htaccess keeps getting reset to blank about once a day - any ideas??

Topic Closed

This topic has been closed to new replies.

About this Topic