WordPress.org

Ready to get started?Download WordPress

Forums

.htacess and removing /index.php/ from my urls (7 posts)

  1. amandaquail2000
    Member
    Posted 2 years ago #

    How do I removing /index.php/ from my urls?
    i have read the support documentation but not had any success yet.
    my site is called http://www.mydomain1.com
    however my urls dispay as http://www.mydomain1.com/index.php/postname

    My permalinks options in wordpress are the below and i currently have postaname selected

    Permalink Common Settings

    Default http://www.mydomain1.com/?p=123
    Day and name http://www.mydomain1.com/index.php/2012/04/12/sample-post/
    Month and name http://www.mydomain1.com/index.php/2012/04/sample-post/
    Numeric http://www.mydomain1.com/index.php/archives/123
    Post name http://www.mydomain1.com/index.php/sample-post/

    my ftp file directory hierarchy is

    user
    mydomain1 - wordpress
    mydomain2 - wordpress
    mydomain3 - wordpress

    where do i need to put my .htaccess file for http://www.mydomain1.com ?
    Do i need it in both user and mydomain1 folders?
    is the below code correct for the .htaccess file?
    do i need to add /mydomain1/ or /wordpress/ to the below?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    What urls are entered in Settings -> General? What hosting do you have - Linux or Windows?

  3. amandaquail2000
    Member
    Posted 2 years ago #

    General settings
    WordPress Address (URL) - http://www.domain1.com/wordpress
    Site address - http://www.domain1.com

    I used the index.php file to delete /wordpress/from the urls

    Hosting is windows

  4. esmi
    Forum Moderator
    Posted 2 years ago #

  5. amandaquail2000
    Member
    Posted 2 years ago #

    There is no web.config file in the wordpress folder related to my domain.
    I created one using notepad and added to the wordpress folder

    the /index.php/ still appears in the urls

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    I think you need to discuss this with your web hosts.

  7. amandaquail2000
    Member
    Posted 2 years ago #

    Thanks for your help. I have sent them an email.

Topic Closed

This topic has been closed to new replies.

About this Topic