WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
.htaccess solutions for XML-sitemaps 404 errors don't work (5 posts)

  1. TIEPIEZ
    Member
    Posted 1 year ago #

    WordPress version: 3.5.1
    WordPress SEO version: 1.3.4.4

    I expected the plugin to do this: show XML sitemaps on http://www.diardam.nl/sitemap_index.xml, same as it does on my other sites (on a different hosting provider)

    Instead it did this: display 404 error page

    I did this:
    - Try to disable all plugins except the SEO plugin
    - Try to disable the "404 redirected" plugin I use
    - Google voor solutions and try the .htaccess mod rewrite solution as described here (http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-fix-for-sitemap_indexxml-404-error?replies=30)
    - Found references to a Nginx server and asked my hosting provider if by any chance they use Nginx server (which the don't, they use Apache servers on Linux)

    Finally the hosting provider asked for server requirements for the SEO module, which I couln't find. So I'm asking 2 things here;

    - Can you provide requirements for the SEO module?
    - Can you please help me because I think I have a sort of unique situation (probably caused by my hosting provider's settings)

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. mailworm
    Member
    Posted 1 year ago #

    Do You have CHECKED "Ping Yahoo! & Ask.com"???

    Uncheck, save settings & Your sitemap will be there. Seems to me like a bug.

  3. TIEPIEZ
    Member
    Posted 1 year ago #

    I had them unchecked. So checked and saved. No difference. Next, verified the site with Google Webmastertools and submitted the url. No sigar. About ready to give up I decided to give the .htaccess thing one more try, except in stead of adding the code after what I already had in my .htaccess, I put it before the existing code. Also, I submitted the .htaccess via Yoast's interface this time, in stead of via FTP. I don't know what did it in the end, but now I see my sitemaps. Problem resolved. Thanks for replying!

  4. kjubeck
    Member
    Posted 1 year ago #

    moving the mod rewrite solution before the existing code fixed the issue for me too.

  5. stenspect
    Member
    Posted 1 year ago #

    I thought it might be a memory issue...might still be. In terms of the 404s, I increased the max number of entries from 1000 to 1500 and this resolved the 404 problem. However, I haven't found a problem for the News Sitemap which isn't updating any more.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic