WordPress.org

Ready to get started?Download WordPress

Forums

.htaccess redirection problems (6 posts)

  1. xenon2050
    Member
    Posted 6 years ago #

    Okay so I wanted to have my posts show up with a date format as the url so I followed the instructions in the admin portion of wordpress to edit the .htaccess file so that it worked that was... I already had some information in the .htaccess file, what it allowed me to do is to have index.php to be accessible from when someone types in domain.com/index... After I installed wordpress it stopped working. When I remove the wordpress .htaccess stuff it still doesn't work right. So now my links don't work because I have the links going to domain.com/index instead of domain.com/index.php
    Also whenever I find a link that doesn't work and click on it instead of going to my domain.com/404.php file it goes instead to a wordpress 404 file...
    Does anyone have any ideas? I'm pulling my hair out trying to fix this.

  2. If your .htaccess in not to big try posting it here.

    Try this: turn off the permalinks to get back to domain.com/?p=123 and remove or rename the (backup, backup, backup first) the .htaccess file.

    Once that works, try putting back the permalinks to day and name, and confirm that that works.

    Now do you want domain.com/index.php/2008/06/04/your-post/ to redirect the user the permalink structure? Like this:

    http://domain.com/index.php/2008/06/04/your-post/
    
    send the user to
    
    http://domain.com/2008/06/04/your-post/
  3. Weird. I replied but looks like my reply got "eated".

  4. xenon2050
    Member
    Posted 6 years ago #

    yeah I noticed that... It said there was a reply but then nothing was there even though there was two posts..

  5. And my missing post was so elegant too...

    Have you tried renaming .htaccess and letting WordPress create a new one with the day and name?

    Once that is done, getting the index.php/2008/06/04/post-name-here/ to go to the correct URL should work.

  6. xenon2050
    Member
    Posted 6 years ago #

    Wow your post is back... I might have figured it out... I disabled permalinks, deleted the wordpress stuff from .htaccess and put my other .htaccess stuff in... Then I verified that it worked that way and it did. So then I tried turning the wordpress perma link on without adding to the .htaccess file. As you can imagine the permalinking didn't work but my index.php to index did still work. So I decided to try something a little strange... I read that wordpress needed the .htaccess file in the same directory as the wordpress index.php file, so I made another htaccess file but put it in the wordpress subfolder and so far both seem to be working...

Topic Closed

This topic has been closed to new replies.

About this Topic