WordPress.org

Ready to get started?Download WordPress

Forums

.htaccess Problem Loading A Sub-Directory (2 posts)

  1. palent
    Member
    Posted 7 years ago #

    I have WordPress 2.2.1 loaded in my root directory. I have a subdirectory to a "OS Commerce" catalog script running in it. My problem is that I can't get access to the control panel of the catalog admin. Everytime I try, I get an "error 404" within the WordPress screen. What is puzzling me is that up until a few days ago everything was working fine. The catalog itself is still working fine.

    I came to the conclusion that the problem is in one or both of the .htaccess files. Therefore, I have spent the last couple of days trying figure what the problem is there. I have been trying every variation I could find, both on the WordPress forum and other places, to find a solution to my probrem. Hopefully someone can help me. Following is the 2 htaccess files:

    ******** Root .htaccess ********

    php_flag register_globals on

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    ******** Catalog Admin .htaccess ********
    # $Id: .htaccess,v 1.1 2003/06/20 00:18:30 hpdl Exp $
    #
    # This is used with Apache WebServers
    #
    # For this to work, you must include the parameter 'Options' to
    # the AllowOverride configuration
    #
    # Example:
    #
    # <Directory "/usr/local/apache/htdocs">
    # AllowOverride Options
    # </Directory>
    #
    # 'All' with also work. (This configuration is in the
    # apache/conf/httpd.conf file)

    # The following makes adjustments to the SSL protocol for Internet
    # Explorer browsers

    <IfModule mod_setenvif.c>
    <IfDefine SSL>
    SetEnvIf User-Agent ".*MSIE.*" \
    nokeepalive ssl-unclean-shutdown \
    downgrade-1.0 force-response-1.0
    </IfDefine>
    </IfModule>

    # If Search Engine Friendly URLs do not work, try enabling the
    # following Apache configuration parameter
    #
    # AcceptPathInfo On

    # Fix certain PHP values
    # (commented out by default to prevent errors occuring on certain
    # servers)
    #
    #<IfModule mod_php4.c>
    # php_value session.use_trans_sid 0
    # php_value register_globals 1
    #</IfModule>
    AuthType Basic
    AuthName "OS Commerce Administration"
    AuthUserFile "/home/neverend/.htpasswds/public_html/cookbooks/admin/passwd"
    require valid-user

    ******** End Catalog Admin .htaccess ********

  2. DianeV
    Member
    Posted 7 years ago #

    Many of us have encountered this before. Before you drive yourself crazy with it, I wrote up a few solutions. I was actually trying to solve a different problem, but it solved that one too:

    WordPress admin password protection 404 -- try the one that says Ah, try this one!

    It solves the mod_rewrite problem when WordPress is in the root folder.

Topic Closed

This topic has been closed to new replies.

About this Topic