WordPress.org

Ready to get started?Download WordPress

Forums

.htaccess problem (8 posts)

  1. Lee36
    Member
    Posted 9 years ago #

    I'm having a problem with my .htaccess file. I uploaded it as plain text then renamed it to ".htaccess" and chmoded it to 666. And it just doesn't work with my permalink structure.

    I am sure my host supports mod_rewrite, so that is definitely not the problem. When trying to edit the .htaccess file through the wordpress file manager, I get an internal server error. When checking the error in my logs, it said "File does not exist". But it is definitely there - in the same folder as "index.php".

    Additionally, wordpress seems to acknowlege that the .htaccess file is chmoded correctly, as it doesn't display the recommended .htaccess code.

    I'm just at a loss here. Can anyone help me ?

  2. trevorturk
    Member
    Posted 9 years ago #

    have you tried not uploading a .htaccess file at all, and then doing options -> permalinks and saving your new permalinks structure?

  3. Lee36
    Member
    Posted 9 years ago #

    Yes, I can do that, and it works. But when adding new pages, they return a 404 error. WordPress doesn't update the .htaccess file like it should.

  4. Kafkaesqui

    Posted 9 years ago #

    Are you able to edit any other files through WordPress, such as the theme files? If so, are permissions on these also at 666?

    Try chmoding your .htaccess to 777, and see if it lets you edit it. If that works, take a look at the owner (through ftp) on .htaccess and your other files, and see if they differ.

  5. Lee36
    Member
    Posted 9 years ago #

    Tried chmoding to 777, and no such luck. I am able to edit all of the other files that are chmoded to 666. It's like my host doesn't allow anything to edit an .htaccess file.

  6. tfrederick
    Member
    Posted 9 years ago #

    OK. I took some time off to get some dinner, and came back. Now I looked in my files using FTP and I have no .htaccess file. Why wouldn't I, but more importantly, how do I fix it?

  7. joeedmon
    Member
    Posted 9 years ago #

    Try 755, some hosts block acces to files that have 777. ".htaccess" is considered a hidden file. My .ht file permissions are 644 and my WP install has no problems writing to the file.

    Your FTP client might have settings that allow you to show hidden files. In WS-FTP look for "Remote File Mask" and put "-a" into the field. Filezilla has a menu item under the View menu for showing hidden files.

    I've also found that I can edit .ht files through the site control panel, even when the host doesn't allow FTP access to these files.

  8. joeedmon
    Member
    Posted 9 years ago #

    Another trick is to upload your .htaccess file from your local computer via FTP, even though you can't see the one on the server. This is dangerous if your host has written something special to the file and you overwrite it. It sounds to me though that you are past that stage.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.