WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] .htaccess, permalinks and 500 errors (3 posts)

  1. d00dlz
    Member
    Posted 7 years ago #

    I've tried to search in the forums for my problem and haven't come up with an exact answer yet. So here is the problem:

    I'm using WordPress as a CMS for a business site. To make this happen I've utilized the Static Front-Page Plugin and the site is composed primarily of Pages.

    I just tried to change the Permalink structure (customizing it to: /%year%/%monthnum%/%postname%/). I had not previously uploaded an .htaccess file to the site's root. So, after I updated the new Permalink structure in the admin panel, I created an .htaccess file and inserted these rules that wordpress gave me:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I then uploaded the file to the root directory (wordpress is my site so it is located /) using ftp. When I went to check the site, I got an Internal Server Error 500. I then deleted the .htaccess file from the server, and when I went back to check my site, only the homepage was accesible. I got 404 errors on any other page. I think this happened because the browser was searching for http://mydomain.com/about-us/ for example and that obviously didn't exist because the .htaccess file didn't work.

    Anyway, I re-uploaded various wordpress files and changed the permalink structure back to the default and can now access the site's pages. But my question is, how can I change the permalink structure and upload a valid .htaccess file? Does anyone have any idea why this is happening?

    Thanks

  2. Chris_K
    Member
    Posted 7 years ago #

    Did you look over the troubleshooting stuff on the Permalinks page in the codex?

    In particular, have you confirmed with your host that mod_rewrite and AllowOverride are on and enabled for you?

  3. Chris_K
    Member
    Posted 7 years ago #

    Ya know? Although you should still check into my suggestions above about mod_rewrite and AllowOverride, I wouldn't expect their lack to cause the 500s...

Topic Closed

This topic has been closed to new replies.

About this Topic