WordPress.org

Ready to get started?Download WordPress

Forums

.htaccess not writable if blog is outside wordpress directory (4 posts)

  1. lbessant

    Posted 9 years ago #

    Not sure if this is purely a 1.5 issue[1].

    Currently on 1.5-gamma 2005-02-05, same symptoms on earlier versions.

    If the Blog address is set to the wordpress directory, WordPress can happily create and update the .htaccess file.

    If the Blog address is set to the root of the site (which is how I prefer to have my sites), while everything else works, WordPress tells me that .htaccess is not writable. Same result regardless of permissions. The rules it creates when copied into the .htaccess file and uploaded work as expected.

    I've done some searching and googling, but haven't come across this particular situation.

    Is this a limitation, a feature, or is it just me[3]?

    This is on my test site, not the one linked from my name.

    Thanks

    Les

    [1] My live site is with a host that's on Windows[2] servers, so .htaccess isn't an option
    [2] Yes, I know. Moving to Dreamhost soon :-)
    [3] Always a good possibility

  2. tom_raftery
    Member
    Posted 9 years ago #

    Les,

    I have a similar situation - my blog in not at the root, as you have yours, but in a seperate folder from the WordPress folder.

    I'm also on 1.5 Gamma (03/02/05).

    I noticed that the .htaccess file that I needed to change the permissions on was the blog folder .htaccess file not the WordPress folder .htaccess file.

    Once I did this, I was flying.

    Hope this helps,

    Tom

  3. lbessant

    Posted 9 years ago #

    Thanks - already checked that - the .htaccess file is in the root, and that has had its permissions set - currently at 666, which certainly should be writable by WordPress.

    A further point is that if the blog is not in the WordPress folder, the file editor can't find it to edit. Suggests to me that I've got a wonky setting somewhere that is stopping WP from "seeing" the actual .htaccess file in its correct location....

  4. freshyill
    Member
    Posted 8 years ago #

    I was having this problem. Putting a copy of the .htaccess file in my /blog folder fixed it. I'm assuming that it'll fall back to the normal and correct spot when I eventually move the blog to the web root.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.