WordPress.org

Ready to get started?Download WordPress

Forums

htaccess in windows xp? (6 posts)

  1. lazymonster
    Member
    Posted 10 years ago #

    I run apache and the php modules in Windows XP. I am new to this .htaccess thing. How do I make .htaccess work for me. I loaded the mod_rewrite.so module already. Is there anything that I have to do to make .htaccess work? Right now the Permalinks doesn't work for me, I manually added the rewrite stuff in .htaccess.
    Can anybody help me with it? Thanks in advance.

  2. Anonymous
    Unregistered
    Posted 10 years ago #

    i too am having this problem...

  3. CeeJayCee
    Member
    Posted 10 years ago #

    .htaccess is a *nix only file / override.

  4. oneafrikan
    Member
    Posted 9 years ago #

    I'm having the same problem on my WinXP box as well - installation to my server worked fine, and I have permalinks working, but my local setup isn't - keep on getting a Error 404 message from Apache...

    This is what my .htaccess looks like, based on stuff I've read on the forum:

    RewriteEngine on
    RewriteBase "C:/projects/oneafrikan/www/oneafrikan.com/live/"
    RewriteRule ^archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^archives/category/?(.*) /index.php?category_name=$1 [QSA]
    RewriteRule ^archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^archives/author/?(.*) /index.php?author_name=$1 [QSA]
    RewriteRule ^archives/([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?/?([0-9]+)?/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/trackback/?$ /wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1&withcomments=1 [QSA]

    Can anyone help with this?

    Have I written the rewritebase correctly?
    Should there be a trailing slash?
    Should there be inverted commas?
    Should the mod_rewrite.so line in the httpd.conf file be uncommented?

    Any ideas?

    Thanks in advance.

  5. acrylamid
    Member
    Posted 9 years ago #

    I got problem to with ".htaccess"-file.
    I copy the code I got in "options > permalinks" in to a txt-file that I rename on the server. I put the file in the WP-root folder and after that I cant connect to my blogg or login. I only got a error message.

    (My code:)

    RewriteEngine On
    RewriteBase /~lin/oerjan/blogg/
    RewriteRule ^archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /~lin/oerjan/blogg/wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^archives/category/?(.*) /~lin/oerjan/blogg/index.php?category_name=$1 [QSA]
    RewriteRule ^archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /~lin/oerjan/blogg/wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^archives/author/?(.*) /~lin/oerjan/blogg/index.php?author_name=$1 [QSA]
    RewriteRule ^archives/([0-9]{4})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?/?([0-9]+)?/?$ /~lin/oerjan/blogg/index.php?year=$1&monthnum=$2&name=$3&page=$4 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /~lin/oerjan/blogg/wp-feed.php?year=$1&monthnum=$2&name=$3&feed=$4 [QSA]
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([_0-9a-z-]+)/trackback/?$ /~lin/oerjan/blogg/wp-trackback.php?year=$1&monthnum=$2&name=$3 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /~lin/oerjan/blogg/wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /~lin/oerjan/blogg/wp-feed.php?feed=$1&withcomments=1 [QSA]

  6. thicke
    Member
    Posted 9 years ago #

    This will work under windows. As Ron White would say, "I know. I've seen it do it."

    Make sure you have "AccessFileName" and "AllowOverride" set right in you httpd.conf. You might have to play with the re-write rules a little. If you look at the "error.log", it should tell you where it's trying to go to look for the index.php.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.