WordPress.org

Ready to get started?Download WordPress

Forums

.htaccess gets un-edited - posted Aug 13, 2010 (2 posts)

  1. Jaguwar
    Member
    Posted 3 years ago #

    Not sure how to explain this, because this is such an unexpected result, but I'm going to try.

    I've used "pretty" permalinks from the beginning with this site; once in a while, I'd get 404 errors, and I knew to change permalinks to the default and back again, and all would be fine.

    For some reason, I woke up this morning to find that my site, which was working just fine last night, suddenly didn't understand "pretty" permalinks at all. It didn't matter which kind it was, the site's internal links were giving me a 404.

    I changed permalinks to the default, then edited the htaccess by hand, following the recommendation in the CODEX, then went back to pretty permalinks.

    Nothing.

    When I looked at the htaccess file again, the code I had just added was g o n e! What the heck?

    No idea why this is happening, but I've temporarily solved it by changing the order in which I fix this:

    1.- change permalinks to pretty permalinks
    2.- edit htaccess

    At the time the errors started showing up, I had not added any new plugins or messed with anything directly (i.e. via FTP or cPanel). Still, maybe someone has experienced this and can tell me what might be happening?

    The site is http://www.ClassicCityCourier.com/

  2. DianeV
    Member
    Posted 3 years ago #

    Works fine for me.

Topic Closed

This topic has been closed to new replies.

About this Topic