WordPress.org

Ready to get started?Download WordPress

Forums

htaccess file seems to disable mod-rewrite in Godaddy mutli-site WP install (3 posts)

  1. tintypes
    Member
    Posted 3 years ago #

    I've been trying to create a brand new WordPress 3.0.2 multi-site install (root-level install using subfolders for add'l sites) on a Deluxe (Linux) GoDaddy web host -- with no success. On my first attempt (following to the letter all the various steps and file content changes), I was able to get the expected Super Admin control panel, etc, so the WP end of things looked perfectly fine. But pretty permalinks wouldn't work (only the default setting was functional) and the dashboards and start pages of any sites I created were "page does not exist" error pages from GoDaddy. Since pretty permalinks are said to be diagnostic of whether or not mod_rewrite is functioning properly, and since new site creation using subdirectories requires mod-rewrite, I suspected a problem with mod_rewrite. Two support calls later, GoDaddy steadfastly claimed mod_rewrite was working fine on their end. But my multi-site-enabled WordPress 3.0.2 install still failed to create pretty permalinks or new sites. GoDaddy claims to the contrary, I suspected a problem with mod_rewrite.

    So I just uninstalled everything, deleted my database, and started over. This time I started by testing the basic (NOT multi-site) installation "right out of the box." Pretty permalinks for three dummy posts work fine -- so presumably mod_rewrite is working OK. But this basic install, like my previous basic install (and unlike the multi-access install), has no .htaccess file at the root level. So I decide to create and add a blank one just to see if it has any effect. And voila, pretty permalinks no longer work.

    I know virtually nothing about coding at this level, so maybe I just committed a faux pas that *should* disable mod_rewrite. But my (utterly naive) logic suggests to me that if I can disable mod_rewrite in a basic WP install with a blank .htaccess file, I might very well be doing the same in a multi-site install containing an .htaccess file with nothing other than WP rules. And this could explain why I can't get my multi-site install (with the required .htaccess file containing WP rules) to create pretty permalinks or properly create new sites.

    UPDATE: Pretty permalinks are now working, and empty .htaccess file is still in my root directory. Not sure what happened here. I still suspect something wrong with mod_rewrite in multi-site install, however. So most of what I've said here still applies.

    FYI, I went through the whole "mod-rewrite is not working" thing with GoDaddy support, quoting the troubleshooting section in Andrea Rennick's fine "Creating a Network in WordPress 3.0 (and up)" pdf ebook as follows:

    "cannot login to backend – in this case it really is an issue with mod_rewrite not reading the htaccess file properly. You may need your webhost to add this line in their Apache httpd.conf file: AllowOverride FileInfo Options"

    Andrea states that they should "add this line in their Apache httpd.conf file", but Support claimed this was not something they would/could do. Support told me to add this httpd.conf file to MY root directory. So I tried that and (a) it changed nothing except (b) the WP dashboard slowed to an agonizing crawl. This is the point at which I uninstalled everything and started over.

    Can anyone help with this? Any suggestions on how to get mod_rewrite to work on a WP install with an .htaccess file, or if that isn't the problem, suggestions on what IS the issue, are greatly appreciated. Remember, I'm no code expert, so precise instructions concerning what I need to do will be very helpful. Many thanks.

    --Robert

  2. `This time I started by testing the basic (NOT multi-site) installation "right out of the box." Pretty permalinks for three dummy posts work fine -- so presumably mod_rewrite is working OK. But this basic install, like my previous basic install (and unlike the multi-access install), has no .htaccess file at the root level. So I decide to create and add a blank one just to see if it has any effect. And voila, pretty permalinks no longer work.

    Awesome troublshooting skills & deductive reasoning there.

    you are correct, it IS something with GoDaddy's setup.

    Support told me to add this httpd.conf file to MY root directory.

    Well that was utterly idiotic of them... since that's a "master" control file for apache for the whole box....

    Really the crux of the issue here is GoDaddy. I do see up above that after a time, things *did* resolve and I know in some cases GD take a bit for files changes to propagate, and this might be part of it.

    mod_rewrite is part of the global server commands THEY have access to. The only way you would have access to it is if it were a VPS or dedicated box. ultimately, they are the ones in control of it here.

    WordPress just taps into what is set on the server - if it's not set up the way it's expected (and on many servers the default Apache setup is *not* what we're looking for - but a decent host isn't going to slap out default settings anyway) then of course the subfolder blogs crap right out.

    Believe me, this is as frustrating for me as it is for you. ;) And a long-standing issue here in the forums, specifically with GD.

  3. I do see up above that after a time, things *did* resolve and I know in some cases GD take a bit for files changes to propagate, and this might be part of it.

    GoDaddy CACHES your .htaccess on their servers, so it can take about an hour for things to sync up. They claim to have fixed this as of a year ago, I've heard people complain it's still a problem. YMMV, obviously, but I would keep it in mind.

    Likely your permalinks will break again when the blank .htaccess gets propagated.

Topic Closed

This topic has been closed to new replies.

About this Topic