WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] htaccess creating 500 errors after website move (5 posts)

  1. davegrun
    Member
    Posted 1 year ago #

    Hi, we recently moved our blog from blog.gts-translation.com to gts-translation.com/blog.

    Our ultimate goal is to 301 redirect all the URLs in blog.gts-translation.com to gts-translation.com/blog.

    But now we have a problem: when I adjust the Permalink settings in WP Admin panel it creates a htaccess file and the gts-translation.com/blog works OK and all permalinks are OK. But the links on blog.gts-translation.com return 500 errors. When I delete the htaccess file, the links in blog.gts-translation.com work fine but the links in gts-translation.com/blog return 404 Not Found errors.

    Can I create a htaccess file that will let both sites work OK? Then I would do the 301 redirect.

    Thanks for helping!

  2. "500 errors" are server-level errors, so talk to your web host. There may be a shared host setting that determines if .htaccess files can run in subdomains and what directories and subdomains inherit .htaccess rules. WP will create an .htaccess file with the correct encoding, so WP probably isn't the problem.

  3. davegrun
    Member
    Posted 1 year ago #

    Thanks, but the 'host' is me: we have our own dedicated server. I already spoke with our support group and they sent me to this link:
    http://stackoverflow.com/questions/5690673/wildcard-domain-redirect-with-wordpress

    But that does not provide a ready solution. Perhaps someone can look that over and tell me what exactly needs to be done?

    Thanks, David

  4. This is really a server admin and config issue and not really specific to WordPress. Get your support group to help, or try http://serverfault.com/

    If you can't do the work yourself, consider looking for a reputable person to do the work from a freelancing site like Elance.

  5. davegrun
    Member
    Posted 1 year ago #

    Thanks, we solved the problem in the meantime by pointing the subdomain to a new, empty folder. Then we created a wildcard 301 redirect in WHM CPanel. It worked and I am now closing this thread.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags