WordPress.org

Ready to get started?Download WordPress

Forums

HTACCESS and ROBOTS For Root Blog and Subdomain Blogs (2 posts)

  1. markosys
    Member
    Posted 3 years ago #

    Hello,
    I have wordpress installed in root ynotdo.com

    and have many subdomains example1.ynotdo.com, example2.ynotdo.com...

    I have the same .HTACCESS and ROBOTS.txt file in each directory. Root and all subdomains.
    Recently I have been getting lower traffic at my blogs so I was wondering if I made a mistake somewhere.
    Is there anything wrong with these and does it look ok?

    Should I use the same files in root and subdomains?

    Please help me to make it better.

    I don't know if it's bad for affiliate links ( adsense, cj....)

    This is .htaccess file that I am using:

    ErrorDocument 404 /index.php
    ErrorDocument 400 /index.php
    ErrorDocument 403 /index.php
    ErrorDocument 500 /index.php
    ErrorDocument 401 /index.php

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    <files .htaccess>
    order allow,deny
    deny from all
    </files>

    ServerSignature Off

    <files wp-config.php>
    order allow,deny
    deny from all
    </files>

    <Files install.php>
    Order Allow,Deny
    Deny from all
    Satisfy all
    </Files>

    <files readme.html>
    Order deny,allow
    deny from all
    </files>

    <IfModule mod_rewrite.c>
    RewriteEngine On
    # If subdomain www exists, remove it first
    RewriteCond %{HTTP_HOST} ^www.([^.]+.[^.]+)$ [NC]
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
    </IfModule>

    # If requested resource does not exist as a file
    RewriteCond %{REQUEST_FILENAME} !-f
    # and does not end with a period followed by a filetype
    RewriteCond %{REQUEST_URI} !..+$
    # and does not end with a slash
    RewriteCond %{REQUEST_URI} !/$
    # then add a trailing slash and redirect
    RewriteRule (.*) $1/ [R=301,L]

    RewriteEngine On
    RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    RewriteRule ^(.*)$ index.php [F,L]
    </IfModule>

    Options All -Indexes

    Robots.txt file:

    User-agent: *
    Disallow: /cgi-bin
    Disallow: /wp-admin
    Disallow: /wp-includes
    Disallow: /wp-content
    Disallow: /author
    Disallow: /wget/
    Disallow: /httpd/
    Disallow: /i/
    Disallow: /f/
    Disallow: /t/
    Disallow: /c/
    Disallow: /j/

    User-agent: Mediapartners-Google
    Allow: /

    User-agent: Adsbot-Google
    Allow: /

    User-agent: Googlebot-Image
    Allow: /

    User-agent: Googlebot-Mobile
    Allow: /

    User-agent: ia_archiver-web.archive.org
    Disallow: /

  2. markosys
    Member
    Posted 3 years ago #

    Any help is good

Topic Closed

This topic has been closed to new replies.

About this Topic