WordPress.org

Ready to get started?Download WordPress

Forums

.htaccess and Permalinks Problem (5 posts)

  1. nickdominguez
    Member
    Posted 9 years ago #

    Here is my problem:

    I've created "pages" in my wordpress installation and now would like use cleaner URI's, ie. point the pages to directories.

    My wordpress installation did not create an .htaccess file so I create a blank .htaccess file, upload it, and CHMOD it to 666. I then go into my WP admin and change the permalink structure. When I do this I get a "Forbidden" error on the site.

    If someone is familiar with this problem please let me know how I can fix it. Maybe i'm using the wrong permalink structure? Or maybe I have to add some extra code to the .htaccess file that I don't know about?

    I'm hosting the site on mediatemple if that helps diagnose the problem at all.

  2. oriecat
    Member
    Posted 9 years ago #

    Did you make sure that the .htaccess is in the right folder? That was my problem at first. I just had it in the root folder, but I needed it in my blog folder where wp lives.

  3. nickdominguez
    Member
    Posted 9 years ago #

    Thanks for the reply oriecat, I eventually figured it out. Apparently if you're hosted on mediatemple you need to add 1 line of code before your rewrite rules, which I wasn't able to do because everytime I implemented the .htaccess file my site would error. So what I did is go into my web control panel and edited the .htaccess file, adding that line of code which seemed to do the trick.

  4. leofish
    Member
    Posted 9 years ago #

    hello,
    I am having the EXACT same problem. I am on media temple hosting as well using WP1.5
    and I cannot

    what was that one line fo code you added. i.e. did you create a .htaccess, chmod 666 and then insert the req 1 line of code? please advise and thanks much.

    too bad can't use categories for permalink on apache pre v2

  5. leofish
    Member
    Posted 9 years ago #

    OK,
    So I added
    Options -Indexes +FollowSymlinks to my .htaccess, chmod 666 and enabled permalinks
    and it appeared to work in my root dir (Blog URI).

    BLOG URI: http://www.expatguides.com/
    WP URI: http://www.expatguides.com/wp/

    However, when I add a post summary and click on CONTINUE READING in my POST it will now show the remaining article and instead point to Archive summary list.

    I did not modify .htaccess REWRITE Rules as above to modify link. Do I need to manually change the REWRITE rules.

    I have lost 2 solid days reading Media Temple pages and these pages. I am close but no cigar and close to giving up.

    Thanks for any help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.