WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] How to use editing feature (12 posts)

  1. halleck
    Member
    Posted 5 months ago #

    I have the premium plugin and would like to have a volunteer edit the translations. Each time I hover over the text I do not see this option. My theme is Elegant themes.
    Thank you!

    https://wordpress.org/plugins/google-language-translator/

  2. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    Hi halleck, I would like to help you with this - there are a couple of things that you need to do, but very simple.

    1) Start by navigating to this Google Translate account page below. You must have a Google account to access the pages after this:

    http://translate.google.com/manager/website/add?hl=en

    2) Once you are signed in, Google will ask you "Website URL" and "Website Language". The individual settings won't matter to accomplish our goal, so choose anything you want here and click "Next".

    3) The next page will be more settings - skip all of these setting and click "Get Code" at bottom of the page.

    4) You will now see 2 snippets of code.....we are only concerned with the first piece of code - the code that you need to place in the header. Copy and past that code into the <head> </head> section of your header.php file. SAVE.

    5) Navigate to WordPress Dashboard > Settings > Google Language Translator. Be sure to "turn on" translation management. Also make sure that you have most current version (v3.0.2).

    6) Navigate to your homepage, then switch to a language other than your default language. You will now see a pop-up from Google that allows you to edit translations for your website.

    That should give you a good start. Please post back here and let us all know how it goes - you will likely have more questions as you learn how it works.

    Best of luck! You will like this feature.

    Thanks, Rob

  3. halleck
    Member
    Posted 5 months ago #

    Thank you for the help. I have done everything but still do not get the editor to pop up when I hover over the text I need to change. I placed the code in the header php between the tags, turned on translation feature installed the plugin and signed on to google on my computer. Any ideas if I missed something?

  4. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    Hi halleck, I'm sorry this is not working for you. If you want, I can take a look at your site for a start. Would you mind sending me a link to your site. You can reach me here:

    http://www.studio88design.com/get-in-touch/

    I'm sure we can get this working.

    Thanks, Rob

  5. Rob Myrick
    Member
    Plugin Author

    Posted 4 months ago #

    Hi halleck, did you get this figured out? Let me know so that I can help.

    Thanks, Rob

  6. halleck
    Member
    Posted 4 months ago #

    Hi Rob
    Thank you so much for your reply. I was able to get it working...thanks for all your help.

  7. Rob Myrick
    Member
    Plugin Author

    Posted 4 months ago #

    That's awesome news, seriously. I don't think many are using this great feature, so I'm glad you were able to take advantage of it.

  8. eosterman
    Member
    Posted 4 months ago #

    I'm having the same problem, but I am unable to correct it with the suggested steps. I have the meta tag embedded in the <head/> section. Translation works just fine, but when I mouse over any text, the option to contribute a suggestion is not presented. I'm signed into Google and have enabled "Turn on translation management?" in the wp-admin settings.

    I do see this error on the console: Blocked a frame with origin "http://translate.google.com" from accessing a frame with origin "http://www.bnbcrm.com". Protocols, domains, and ports must match. jquery-1.8.0.min.js:2

    Here is my site:

    http://www.bnbcrm.com/

    Thanks!

    -Erik

  9. Rob Myrick
    Member
    Plugin Author

    Posted 4 months ago #

    Hi eosterman, I'm sorry you are having this issue. Would you mind trying out something for me? Would you please turn on the translation box in Settings > Google Language Translator, and then let me know if "Edit Translations" works at that point? This might be a correction I need to make.

    Also, you must make one translation away from default language before the Edit Translation feature activates.

    Thanks!

  10. eosterman
    Member
    Posted 4 months ago #

    Sorry for the late response. I did not have internet access while in Cambodia.

    I enabled "Translation Box". Fwiw, I also have it in "Horizontal mode", but I don't see the box, so maybe it is wrapping off the screen? In the preview screen on the settings page the drop down selection box is also not horizontal, but appears below the flags.

    I still don't see the edit option. I also do not know how to do "one translation away from the the default language" because I'm not sure where that is done.

    If I put the URL into http://translate.google.com/, with the extension enabled, I am not given the option to see the edit dialog. If I disable the plugin, then go to the translation site, I once again see the edit option.

    I have left the plugin enabled along with the translation box. Let me know how else I can help.

    -Erik

  11. Rob Myrick
    Member
    Plugin Author

    Posted 4 months ago #

    Hi eosterman, I just fixed this issue in the latest update - I can see it's now working on your site. I'll close this out for now - but please let me know if you experience further issues.

    Thanks, Rob

  12. eosterman
    Member
    Posted 4 months ago #

    Beautiful! Problem solved. Thanks again! This is such a sweet approach to language translation.

    -Erik

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.