WordPress.org

Ready to get started?Download WordPress

Forums

How To Upgrade From 1.5 to 1.5.1.3? (46 posts)

  1. hampshire
    Member
    Posted 9 years ago #

    On the Upgrade Page I see information on:

    Upgrade_1.2_to_1.5
    Upgrade 1.5.1.2 to 1.5.1.3

    but I see nothing on how to upgrade from 1.5 to 1.5.1.3 and I can not find the older upgrades that come between these versions so I can do them one at a time. Anyone have any advice.

  2. moshu
    Member
    Posted 9 years ago #

    Just follow the 1.5 to 1.5.1. or 1.5.1.1...

    Edit. http://wordpress.org/support/topic/33189

  3. hampshire
    Member
    Posted 9 years ago #

    Where am I looking on that page and for what?

  4. moshu
    Member
    Posted 9 years ago #

    The very first post is how to upgrade from 1.5 to 1.5.1.
    You don't need to upgrade to 1.5.1 then to 1.5.1.1, then 1.5.1.2 etc.
    Just follow those steps described at the link above and you will be fine: basically all the upgrades go by the same pattern.

  5. loride3
    Member
    Posted 9 years ago #

    Did all this and all seems well, but have some files from 1.5 version that don't appear in new version is it safe to delete them?
    I know NOT to delete wp-configure.php, but what about these: wp-locations.php, wp-layout.php, wp-comments.php, wp-comments-reply.php, wp-comments-popup.php, print.css, fantversion.php and the error-log.
    Do I need these?
    Thanks in advance!
    Lori

  6. Sire
    Member
    Posted 9 years ago #

    I did everything according to instructions, upgrading from 1.5 to the latest, deleted all the files except wp-config.php and wp-content folder, run the upgrade and it said it was fine but all I got was a blank screen. When I tried to log in I get the following
    Fatal error: Call to undefined function: get_bloginfo() in /home/t/*****/www/*****/wp-login.php on line 11

    Lucky I backed up the old files. Any ideas?
    Peter

  7. Sire
    Member
    Posted 9 years ago #

    Fixed, it seems some files were not uploaded, deleted them again and uploaded again, all is now fine.

  8. compa6
    Member
    Posted 9 years ago #

    I have to say that WordPress, while a very nice piece of coding, needs a LOT of work. The things that need to be done for a simple upgrade are ridiculous. A new install everytime the dev team changes one line of code is insane and anyone who thinks it is "not a big deal" is simply out of touch with what peoples' time is worth.

    I liked WordPress enough to spend time on the learning curve to install and use it (and it wasn't a smooth install). I thought that those minor tweaks I had to do were a one time thing (I didn't document every little adjustment I made to make this thing work). Now it appears I have to do it all over again since the dev team thinks it is "OK" to force me to replace every file out there instead of just the files that were changed.

    Also the bit of advice to Backup and then test your backup files before upgrading ...WHAT? Do you think that everyone is running a webserver on their computers? Not to mention PHP and SQL.

    BAHHHH

    Jim

  9. skippy
    Member
    Posted 9 years ago #

    The upgrade instructions are fairly clear, I think.

    If you are using WordPress 1.5.1.2, you can simply replace these files, and be done.

    compa6: I see that you've been a registered member of these forums for 18 minutes. I encourage you to help us improve the upgrade documentation. I also invite you to help us here answering upgrade questions. The number of variables at play between everyone's hosts, their configurations, and their level of technical accumen varies wildly.

    As I said here, the "full suite upgrades" of WordPress are an attempt to minimize at least one of those variables. By having a single process for uploads, it eases the burden on the support volunteers who spend their time here, helping folks.

  10. kickass
    Member
    Posted 9 years ago #

    Please before reading this-- I love WP, I love you guys, I think this is one of the best communities around!

    Having said that, I feel the rest of this really needs to be said, and I'm trying to say it gently and so I don't hurt any feelings or anything. But my frustration level with this issue is high right now. Please take that into consideration as you read, and don't take anything personally. And TRY to understand what I'm saying and where it's coming from.

    Respectfully, if the upgrade instructions were "fairly clear" I think there would be less posts on the support board from people with frustrations that are the result of following them. I'm fairly good at following clear instructions, and I'm pretty good with xhtml/css and with making edits to php and an occasional change in that code, though php isn't my strongest talent. I install scripts all the time. I even make the occasional minor edit to them. I design small business websites for bucks. I'm not a noob.

    I read the instructions in the codex on the "Upgrading WordPress" page. Clear instructions are not at all what I'm seeing, so consequently I'm really not wanting to do this upgrade. If I feel this way, how do you think a noob must feel? Directions for "major" and "minor" upgrade are all mixed up in the "detailed" part of that page with no mention of version numbers, and it's easy for people to misunderstand. Version numbers are all so similar and not spelled out clearly so you have a clear path to follow. I know for a fact I don't understand.

    You say, "I encourage you to help us improve the upgrade documentation." Help with the docs? How can anyone do that when they can't understand them? I know they need edits. I'm telling you they need edits. But I'm not qualified to do them. I'll be damned if I do and cause someone else the same frustration I'm feeling.

    Meanwhile I'm seeing a lot of posts on this support forum from people who do the upgrade (major? minor? who knows?) and have problems with permalinks (Oh no! Not that! It took me ages the first time!) and rss feeds after upgrading. Why is that information on dealing with that in the wake of the upgrade not in the Codex on that upgrade page, where it will be easy for people to find? The issues keep coming up over and over as a result of this upgrade. I've also gotta wonder if those issues come up because the differences between major and minor and who is supposed to do what are really mixed up in a lot of places.

    With so much confusing information I think I'll leave my current install (1.5) up until my host tells me to change it OR until someone edits that "Upgrading WordPress" page so I know what I have to do.

    For instance-
    Upgrading from 1.<5 to 1.5.1.3
    Upgrading from 1.5 to 1.5.1.3
    Upgrading from 1.5.1 to 1.5.1.3
    Upgrading from 1.5.1.2 to 1.5.1.3 (this one is there, kinda, though mixed in with other stuff)
    And maybe leaving out the "major" and "minor" stuff completely. Yes, I know there will be some duplication of material, but if it makes it clearer for people to follow, and lessens the load on the support board, is that a bad thing?

    Please help us out here.

  11. skippy
    Member
    Posted 9 years ago #

    Per-version upgrade instructions are one of the things that we hope to avoid by providing only a full download link. The upgrade process is basically the same for any version of WordPress 1.5 or above:
    * delete all old files EXCEPT /wp-config.php and /wp-content/
    * upload new files
    * run upgrade.php

    To make seperate instructions for each of 1.5, 1.5.1.1, and 1.5.1.2 not only duplicates our efforts, it requires end users to know which version they have, and to find the appropriate upgrade document.

    If you're upgrading from WordPress 1.2 or below, then special care can be taken to convert your site design to the new WordPress theme system.

    A lot of the complaints we're receiving are coming from people who have made modifications to the core system. The truth is, there's very little we can do to make it easy for all of these users to upgrade seamlessly. If you're willing and able to make modifications to core WordPress files, then it is entirely your responsibility to keep track of what changes you've made, and to re-apply them after an upgrade. If you're willing to modify code, and you want patches or changesets, then you can follow the revision histories at trac.wordpress.org.

    Permalinks -- and other items -- are breaking for various reasons. I haven't read enough of these threads to discern a reliable pattern. If anyone has noticed such a pattern, please email me and I'll do what I can to get that information into the upgrade documentation. Again, the number of variables at play are many, and posting detailed instructions for resolving some issues might scare even more users away from upgrades.

    We're never going to make everyone happy. We're trying hard to provide support to everyone who needs it.

  12. vkaryl
    Member
    Posted 9 years ago #

    One thing you CAN do to clear up a little fuzziness, skippy, is to specify that in this list item:

    * delete all old files EXCEPT /wp-config.php and /wp-content/

    /wp-content/ is a reference to a FOLDER. You might not believe how many people out there who use (or would like to use) a program - any program not just WP! - don't understand they need to keep the whole FOLDER, and spend ages looking for a file named wp-content (or whatever.... because this isn't just a problem here, though that's what's being addressed just now....)

    Now, I personally have not found the upgrade process to be onerous (especially since I simply used the list of changed files the last couple of times - but I feel confident enough with my nerd skills to do that....), but it is apparent that many many people do have a hard time with the whole thing. This is not only people who simply don't have the skills, this is also people who use a great deal of open source software and are used to a totally different patching system.

    I believe it's already been stated that the update/upgrade system is probably not going to change; that's something that each person must deal with and make decisions about on hisser own. I personally feel that a system similar to that which has served phpBB quite well for many years now would be preferable (for those who don't know, the phpBB system provides a complete file download as well as a changed files only and a patch file download) - but if that's not in the cards, okay - I'll deal with it.

    Others who aren't as willing to mess with it as I am though.... (and their name IS legion.... due to what WordPress has lately become) - those folks are going to continue to not get it, and get testy and frustrated as a result, and ultimately many may jump ship, back to something simpler. I guess that could be classed as "natural attrition"; but the things that WP seems to me to have in abundance (as opposed to "other" similar software) - that is, an engine that's classy, does nearly all things for all people, and is almost infinitely customizable, and never forgetting the great volunteer "staff" around here! - will eventually suffer greatly if people start moving wholesale....

    Um. Okay - that's way too long for "2 cents worth". Sorry - for the post-length, but not for what I posted....

  13. skippy
    Member
    Posted 9 years ago #

    We have slightly adjusted the Upgrade Documentation, and we welcome feedback -- positive and negative. We write documentation to save us all time, in the long run, so if the documentation can be improved further, please let us know.

    We use a wiki for our documentation, and we encourage people to participate. If you're uncomfortable making changes directly to the document, please share your thoughts on the discussion page, so that we can do our best to incorporate your suggestions.

  14. richards1052
    Member
    Posted 9 years ago #

    I too appreciate all the fine work done by volunteers to produce the upgrades & maintain this forum.

    But I'm afraid I have to echo the criticisms of others above. Carthik Sharma installed 1.5.1 for me a month ago & I have not upgraded since. And I'm petrified to do so. In that month's time, I've modified many files (patches, hacks, etc.) based on instructions fr. plugin authors & suggestions in threads here. I never kept a log of what I changed because I never read a suggestion to do so here in this forum (until today). I'm not a professional. I'm not used to keeping logs. And even if I do keep one, how do I know what information needs to go into it in order to help me through the next upgrade? Of course, I can guess & add that to the log. But as an amateur, I'm sure I'll miss something or many things. If I upgrade, then I'm certain I will lose many, if not most of those modifications & basically have to start over as far as they're concerned.

    So when I read a short but terrifying phrase like "delete your old WordPress files" in the Codex instructions on upgrading, I freeze like deer caught in the headlights. What do they mean by "WordPress files?" And how do I distinguish between files I need to keep that I may've altered & files I can trash?

    I guess I'll have to wait for Carthik to return to the States & then I'll have to hope he has the time to help me.

    I have visions in my head of the havoc I could cause to my blog by trying to do this myself.

    Like phpbb, Firefox too has an option for upgrades to install only changed files. And I find most FF upgrades to be a dream in terms of ease (though you do get the occasional bug). That would make life so much easier for WP users.

    I read the WP volunteers in this forum as trying patiently to explain why WP must do things concering upgrades in a certain way. But what I don't hear enough fr. them is a realization that so many people are having these problems that there needs to a fundamental conversation about how things can be made a little easier for folks like me & the others who've posted similar sentiments above. Pls. at least consider creating a "changed files only" upgrade version.

  15. You should upgrade ASAP. Your blog is at risk due to the number of publicly known security exploits that have been fixed since v1.5.1.

    Angsuman has created this "changed files only" patch to upgrade from v1.5.1.2 to v1.5.1.3:

    http://blog.taragana.com/index.php/archive/wordpress-patch-upgrade-from-1512-to-1512-made-available/

    And, Shaky has created this "changed files only" patch (based on Angsuman's) to upgrade from v1.5.1 to v1.5.1.3:

    http://www.shakykaiser.com/blog/archives/2005/07/17/wordpress-upgrade/

  16. Lorelle
    Member
    Posted 9 years ago #

    As someone experienced about WordPress and also suffering from "upgrading-deer-caught-in-the-headlights" thing, I put off upgrading the smallest patch. I understand what you are going through, but we have a couple of issues that need to be dealt with.

    1) You trusted someone else to install the program for you and then you went ahead and "did" things to it with little or no experience. Have you learned anything during the process? Weren't those plugins, hacks, template file changes and so on educational? Have you learned anything about how WordPress works? Just curious. This kind of learning should ease your fears.

    2) The changes you have made are within your /wp-content/ folder. It says VERY clearly that folder is to be left alone in the upgrade instructions. That is the folder that holds your themes and plugins. Leave them alone and nothing will happen. Screw with them every time you add a plugin or mess with the theme templates and you will have problems without running the upgrade. If you made changes to the core files, which is warned against repeatedly here and in the Codex, and didn't take notes, which is also advised here and in the Codex, then you made a mistake. And you will lose those changes. Fact of life when you go into the core programming. But the Themes and Plugins can be messed with all you want and nothing will happen to them if you don't delete that folder.

    3) MANY people are working on ways to improve this process. Give them time to work out all the bugs associated with the thousand and one ways people install and use WordPress. I am continually boggled at the myriad ways people come up with for intalling WordPress. To make a good upgrade program, they have to think about all these different installs.

    4) One of the ways things get done around here, all by volunteers as you mentioned, is that someone sees a problem and comes up with a way to fix it. I don't know if this will help you, but I got tired of reading about everyone's whines and decided to get past my own fears and procrastination and documented EVERY step of the process on my site. Maybe that will help you, too.

    5) Carthik is a very busy volunteer. Because you got handholding once, does not mean he or other volunteers will repeat the process. ALL of us give what free time we have to this process without any payback. If you follow the instructions, your world will not end. All is fixable and you have the BEST here to help you.

  17. richards1052
    Member
    Posted 9 years ago #

    Macmanx: Thanks for those references. I'll try Shaky's patch since I'm upgrading fr. 1.5.1.1 t0 1.5.1.3. I think that should be easier than doing a full upgrade installation. I'll be brave, I'll be bold, I'll bite the bullet (& hope the bullet doesn't bit me back!).

    Lorelle: Thanks for your comprehensive reply which lays out a lot of good points. Yes, I've learned immense amts. about WP & other technical issues surrounding my new blog through the entire process of basic & plugin installation. I'm sure that in 6 mos. or a yr. after I have more of this technical stuff under my belt I'll be wiser, more experienced & more confident in knowing my way around.

    When I first started using Firefox, the upgrades & extensions & bugs were intimidating & frustrating. Now, I feel much more confident (& perhaps they've taken some of the bugginess out of the software in the past 2 yrs. or so). I expect some of that will happen to me w. WP as well.

    It may appear that I'm asking for a lot of handholding. I'm really trying to fend for myself and fix as many problems & bugs as I can both on my own & through reading this forum & other resources. And don't think I take Carthik's help (or any volunteer's help given here) for granted in any way. There are some issues though that simply surpass my 8 wk. old level of experience w. WP.

    But with all that--let's keep learning. I'm not giving up on my own ability to master this thing yet nor am I giving up on WP despite some level of frustration with it at times.

  18. blog4
    Member
    Posted 9 years ago #

    Simple Question: At the bottom of my WP Dashboard it reads "Word Press 1.5". Does this mean 1.5 , it might it mean 1.5.1 ? Put another way, how do I look and see what edition I am running?

  19. Mark (podz)
    Support Maven
    Posted 9 years ago #

    It shows the full number there
    Up to date is 1.5.1.3

  20. blog4
    Member
    Posted 9 years ago #

    Therefore, if it shows 1.5 , I must first upgrade to 1.5.1.
    Then, can I go straight up to the lastest editon? Or, must I make other local stops along the way?

  21. Mark (podz)
    Support Maven
    Posted 9 years ago #

    You can go straight to 1.5.1.3

  22. blog4
    Member
    Posted 9 years ago #

    Finally, I have looked but can't find the upgrade 1.5 >1.5.1 . Can you point me there?

  23. Mark (podz)
    Support Maven
    Posted 9 years ago #

    You mean a guide ?
    Or certain files ?

  24. blog4
    Member
    Posted 9 years ago #

    A download of files. There is a support entry here on upgrading from 1.5 > 1.5.1 which says in part:
    1. BACKUP your database
    2. Download 1.5.1. Unzip it.
    3. Open the unzipped folder ...
    My question is: Where is this "1.5.1" that I need to unzip?

  25. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Oh... that must be an old entry.

    From the link at the very top of the page, click Download and get the file there.

  26. blog4
    Member
    Posted 9 years ago #

    "The" page? Which page? It's not this page. Nor is it the download page which provides a 1.5.1 > 1.5.3 upgrade.

  27. To upgrade from v1.5.x to the current release, follow the instructions here: http://codex.wordpress.org/Upgrading_WordPress#Overview

  28. blog4
    Member
    Posted 9 years ago #

    Okay. I have been to that file/instructions. I must have misread them. I thought that that download was good for 1.5.1 > 1.5.3 . I assume now from your directions above that this download will take me straight from 1.5.0 to 1.5.3 -- one upgrade, using one upgrade download. Correct?

  29. Yes

  30. Matoo
    Member
    Posted 9 years ago #

    I just upgraded from 1.5 to 1.5.1.3
    I followed the instructions : deactivated the pugins, deleted all files, uploaded the new ones... I ran "wp-upgrade.php" and... nothing ! I just had the upgrade page step 1 but no page told me that the upgrade was done. Although it seems that everything is working. I reactivated the plugins, made the changes (locale, vars, plugins adjustments for antispam etc.), and my blog seems to be in 1.5.1.3. But is it normal ? Running wp-ugrade.php was not necessary then ? I'm a bit lost...

    Besides, now the only concern I have is about "Options/Discussion". It seems that all comments are going to the moderation queue, but I did not check the option (Comment author must have a previously approved comment). It's like the action i'm taking here is not relevant in the system ?

    Help. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags