WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms Salesforce Add-on
How to trigger Auto-Response Emails with Salesforce API plugin (7 posts)

  1. emaginetodd
    Member
    Posted 10 months ago #

    We have a client who is currently using Salesforce on their new WordPress Site. Prior to the new site, they set up Auto-Response rules that were working on their old site.

    After building a new website, we are successfully able to post web-to-lead submissions; however, the auto-response emails are not triggering.

    Based on what I've learned, it seems that any custom API calls to SalesForce will not fire off these auto-response triggers.

    1) When creating SalesForce feeds in Gravity Forms, I set up the Salesforce Object to 'Lead'. Does the API make an HTTP post to https://www.salesforce.com/servlet/servlet.WebToLead?encoding=UTF-8 ? Or is it posting to Salesforce using a different method?

    2) Is there a way to modify the plugin to pass on the function triggerAutoResponseEmail OR can we create a hidden field in Gravity Forms that will make the triggerAutoResponseEmail true in the API?

    -Todd

    http://wordpress.org/plugins/gravity-forms-salesforce/

  2. emaginetodd
    Member
    Posted 10 months ago #

    Hmm, in addition to the API plugin not firing off Auto-Response rules in SalesForce, it also appears that the API plugin does not trigger SalesForce lead assignment rules.

    These are two make-or-break functions necessary for our users.

    I have found the following 2 Salesforce Support pages for my information:

    Why does auto response not work with Cases/Leads that are created via the API?
    http://help.salesforce.com/apex/HTViewSolution?id=000004302&language=en_US

    Assignment rules do not send notification email for Leads/Cases created via the API
    http://help.salesforce.com/apex/HTViewSolution?id=000003781&language=en_US

    Any information on how we can help extend the plugin to accommodate these two features is GREATLY appreciated.

    Thanks,
    Todd

  3. Gschmeidler
    Member
    Posted 8 months ago #

    Were you able to resolve this issue? I have posted the same question quite a while back and never got a response.

    Glenn

  4. RetireIT
    Member
    Posted 5 months ago #

    Any response on this? I'm having the same issue.
    Thanks,
    Kyle

  5. RetireIT
    Member
    Posted 5 months ago #

    Is there anyway to do this manually with Gravity Forms?
    http://help.salesforce.com/apex/HTViewSolution?id=000003781&language=en_US

    I'm not a developer. When I create custom fields for AssignmentRuleHeader and EmailHeader, no luck.

    Please advise.

    Kyle

  6. Zack Katz
    Member
    Plugin Author

    Posted 5 months ago #

    Please read the FAQ item "My Assignment Rule is not triggered. How do I fix this?"

    If this doesn't meet your needs, please pay for Premium Support and we can create a solution that works for you.

  7. Zack Katz
    Member
    Plugin Author

    Posted 5 months ago #

    Also, the answer to #1 is no: when using the API version of the plugin, it does not post to the servlet.WebToLead URL; it uses the API.

Reply

You must log in to post.

About this Plugin

About this Topic