WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] how to switch back from permalink changing (14 posts)

  1. WildMagic
    Member
    Posted 6 years ago #

    i happened to change permalink setting, and my host provider doesn't support .htaccess, so wp just crashed. The problem is, after reparing the server, i cann't switch the permalink option back since this will cause the server crash again and the switching is not saved then, is there any way to directly modify the saved option back, or what else can i do about it?

  2. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Switching back to default shouldn't cause wp to crash. Keyword shouldn't. I've never run into anything like this before. I advise you to make backups if you have any content yet.

  3. WildMagic
    Member
    Posted 6 years ago #

    thank you, but the switching back thing does cause crash because the host provider does not permit .htaccess.

    i mean, is there any way to switch the permalink option back through modifying the database content?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Just switch it back to default, and then manually delete the .htaccess via your FTP.

  5. WildMagic
    Member
    Posted 6 years ago #

    but i cannot switch it back to default, because wp will create .htaccess when i open the permalink page, at that time, the server already crashed and stopped responding to my request.

  6. WildMagic
    Member
    Posted 6 years ago #

    is there any manual way to switch permalink option back? i'm in an emergency, can anybody help me?

  7. WildMagic
    Member
    Posted 6 years ago #

    problem solved.

  8. 8unknown
    Member
    Posted 6 years ago #

    hi
    I have a similar problem.
    I modified the permalinks options but my server doesnt support mod_rewrite.

    I did get the error 500 internal server, even when accessing admin panel.
    I got access to it again by deleting .htaccess. but now, my posts permalinks are broken, and everytime i try to change the permalink options again to restore it to default, it probably create a wrong .htaccess file and fail to save the default permalink option.
    and then i get the whole error 500 again and loose again access to my admin panel for wordpress.

    this is really ugly. i hope people could create a blog that repair itself when something wrong happens, cause wordpress didnt warn me at any stage that changing the default setting could kill everything... how annoying...

    so wildmagic, if u have a solution, please share!
    thank you everyone

  9. puckrat
    Member
    Posted 6 years ago #

    I had set permalinks away from the default setting then could not access my website -- getting HTTP 500 Internal Server Errors on both front-end and admin interface.

    Of course, I have since then found out that permalinks won't work on a Windows server since they require use of the .htaccess file which Windows servers do not support.

    Since one can't access the admin interface, it's off to the database. In the database, try setting wp_options table permalink_structure option_value to null.

    Not *positive* this was the issue or the cure, but at least coincidentally I am able to access my WP install now after making that database change.

  10. puckrat
    Member
    Posted 6 years ago #

    Drat, can't edit. ... I also set the wp_options table recently_edited option_value to null.

  11. yanzhg
    Member
    Posted 6 years ago #

    I also have this trouble!
    who can help us!
    Thank you!

  12. WildMagic
    Member
    Posted 6 years ago #

    Here is my solution: (1) open "options"->"permulink"; (2) set the option back, but don't save it, just leave the brwoser open; (3) as the .htaccess has been created inside the server, and http service is crashed already, but you can still use file management functionality provided by the space host to delete that file (4) turn back to the browser and save it, done.

    ps. if your space host doesn't support file management, you can upload a phpmyadmin by your own and operate on it.

    thank yanzhg for your kind reminder.

  13. alliesrr
    Member
    Posted 6 years ago #

    WildMagic, that worked great for me.

    But I'm concerned.. will I keep having this problem?

    I upgraded, everything went fine and then the 500 server errors with the .htaccess bit.

    I figured out the .htaccess yesterday, deleted it, and then realized how my permalinks were broken, so I had to go into every post (omg) and resave.

    Today it spontaneously happened again.

    Fortunately I checked here and did what you said, and I didn't have to resave each one manually, but I'm wondering, will this happen again?

    Does anyone know if this is a WP bug that can be fixed?

  14. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    This is not a WordPress bug, it's a problem with your host and their server. WordPress creating an .htaccess will not cause a 500 error except on a broken webhost. Even if they don't have mod_rewrite support, WordPress includes the IfModule lines, so a properly configured webhost will ignore the new rules in that case.

    My advice: Change hosts to one that doesn't suck.

    Alternate advice: Create a blank .htaccess file and set it to 444 permissions. Then WordPress cannot edit it.

Topic Closed

This topic has been closed to new replies.

About this Topic